No UI and freeze after loading a save

Hi, I’m having this problem on Alpha 20 where when I load up a save and once it passed the loading screen into the game screen. There’s no UI and everything freeze. The only thing I can do is move the camera around. I can’t use the ESC menu. I can click on Hearthlings and objects but no respond. I have only the debug mod and Rayya’s Children on.

Any ideas?

What happens if you press F5?
Does this happen with all saved games?
Did you try loading a different save and then load the save you wanted to load?

Please upload the save you can not load and tell us what version and which mods you are using.

Some users have been experiencing this problem. Seems that a clean reinstall has worked for them. Try this:

  1. Launch Steam.
  2. Right-click Stonehearth and click Properties
  3. Click on the Local Files tab
  4. Click Browse Local Files...
  5. If you have saved games or templates to save, complete the following. Otherwise, skip to step 6 below.
  • For saved games, copy saved_games to another location, like your Desktop.
  • For templates, copy saved_objects to another locaiton, like your Desktop.
  1. Go up one directory level to the common folder.
  2. Delete the Stonehearth folder.
  3. Close Windows Explorer and return to Steam.
  4. Right-click Stonehearth and click Uninstall...
  5. Once removed, right-click Stonehearth again and click Install Game...
  6. If you backed up saves or templates in step 5 above, do the following. Otherwise, skip to step 12.
  7. Right-click Stonehearth and click Properties
  8. Click on the Local Files tab
  9. Click Browse Local Files...
  10. Copy the backed up folders into Stonehearth folder.
  11. Close Windows Explorer.
  12. Launch Stonehearth
  • If this works, great! Please let us know so we can mark this as resolved.
  • If not, please upload your stonehearth.log from the game install directory (follow steps 2-4 if unsure how to access) to the Discourse so we can take a look.
1 Like
  1. Nothing happened. I try to open the console with the debug mod too but nothing happen.
  2. Yes, this does happen all of my save files. Modded or not, it’s all the same.
  3. I did and met with the same result.

Here’s my latest save 1486922588528.rar (2.8 MB)

I have the debugtools mod, smart_crafter and the default Rayya’s Children all of which are latest version of the mods.

It worked! Thanks, Relyss. now I can get back to building my kingdom.

I guess the reason must have been that I still use the same folder for Stonehearth since Alpha 16.

Anyway, keep up the good work with the game and er… what do I do with the topic now? close it?