Game froze after load saving

Hi, today when i loaded my saving it froze instantaneously.
Here the pic of what happened. I can only move the camera nothing more.

here the link of the saving file:
I can’t upload the file “metadata.json”
Hope this help

the file stonehearth.log in your StoneHearth folder is the one that contains the error logs. The metadata.json file is a static file that tells the smod where your entities are located and which mixins, default langage, etc…

uploading the stonehearth.log may shed more light on your situation.:smiley:

Hi, here is the log

Hope this help

I looked at the log and did not see anything there that would cause it. It did end abruptly so it might be something outside the game, like a driver or other issue. can you upload your save file I could see if it does the same thing on my system.

Hi, thanks for the support! I don’t think that that was the case. All my drivers were work fine and I didn’t see any other anomaly. The save file is in the first post is “just” missing the file “metadata.json” . Google drive don’t let me upload that.
The other save files that I have work all fine.

I am glad your other games are still working.
Are you running any mods? As a unique metadata.json file is in each one. If the metadata.json is missing it would be missing for all. The only thing I can think of was there was corruption in the save file referencing the metadata.json.

So there would be the metadata.json for the stoneheath.smod, rayyas_children.smod and rayyas_children_ui.smod for the base game. Each one would have a metadata.json which identifies the file location, mixins and language.

Someone better versed would have to address this issue as I am stumped.

@8BitCrab have you seen this issue before. It is only effecting a single save game.

i’ve seen a similar issue with it crashing upon loading certain saves, but never just freezing…

Hi, ehm… i am sorry i didn’t know that if I closed the game the log will be deleted… or whatever it works!
I tried to load the save( I don’t use mod of any kind) and then I went to the log.
Surprise ! I get a log of 835 MB yeee😂
I uploaded all the save files and the log ( I erased the last part, but it repeats itself over and over and over)

Here the link :wink: :

Yup it is frozen. The UI never loads so its something with the file and not your system.
I was able to pan around but that is it.
Hopefully one of the developers can look at the save game files and see what type of error is going on.

Hi there,
I looked into this file and have fixed it for you. It is an issue with the blacksmith’s crafter queue. A permanent fix for loading the old save file will be in the next unstable release.
In the meantime, here is the save that will load: (8.8 MB)

Thank you for reporting this!


Thanks guys for the support !

The game is great keep working on ! :wink:


I am also having this issue with my save game. Exact same behavior. Loads up but no crash. I can zoom the camera around and even highlight things but no ui and everything in game is frozen. I tried getting a little clever and downgrading to A16 which worked still, made sure nothing was in any crafter queue and no building wasn’t finished etc. Re-upgraded to A17 and still nothing.

Not that you want to spend your time fixing people’s saves, that is actually somewhat ridiculous, but if you wanted another example of the break you can look at my save game.

Thanks for the hardwork though. Wondering if this issue might be a little more common or maybe myself and OP just got really unlucky. :slight_smile:


I’m looking at your save now. It seems to have something different happening from the previous poster …Working on it.
Thanks for uploading it!


So while the first update after A17 did not fix my save’s issue and it still froze the same way; the latest one did. 3000 lets that save load and run normally again. :slight_smile:

Thanks for the hard work.


Yay! It is thanks to @not_owen_wilson :smiley: He made the fix

1 Like