[Ack] No UI and No Activity on Reload

Played a new game, saved straight off, partway into the first day I saved again and then a third time. Went out, came back and played Stonehearth and the third save loads up yet there is no activity from the hearthlings and no UI, I can scroll the map and rotate the screen. Just tried the first and second saves and they work. Playing the latest unstable build by the way.

could you perhaps supply us with this corrupted save file?

1 Like

No, I deleted it, but… I think I know what might of caused it. When I do my first save on any new game its a safety save. This means a save I use when I have a good map and good set of pioneers. If something goes wrong or I get to a point where I think “If I had only done that…” I can reload and start again. When I saved I had paused the game straight after naming the town. At this point the hearthlings carrying the tools (saw and hunting knife) still had them in their arms. I remember reloading the start save (I had gone out) but this time set harvesting commands. The hearthlings with the tools placed them in their packs. Saved again. I remember trying to assign a carpenter and hunter but couldn’t, the tune played but the would be hunter and carpenter carried on chopping trees. The tools hadn’t been dropped. Once the haulers dropped them the jobs got assigned. After this I carried on saving the 3rd time and got the issue. Not sure if this had a bearing on the game.
Question 8bit, how do I upload a save file if it was to happen again? Same as screenshots?

to upload photos or files use this button,

you should be able to upload the save directly to the discourse if its a .zip file.

hope that helps/makes sense.

1 Like

:grinning: Knew about uploading screenshots, done a few. Wasn’t sure if save files would work the same way. I still had the first (safety) save so tried to replicate the issue but each time they dropped the tools before harvesting.

1 Like

i’ve never actually tried uploading files directly to the discourse, but it should work.

good to hear your save is working fine now! i’ll try and see if i can replicate this in my own world later.

I think i have the same problem. I just loaded my game and no UI or activity. I did notice the game’s RAM kept rising. it started at around 2g and i had to shut it off at around 12g, but it probably could have kept going. I have a save but its too big to be uploaded here :confused:

that is most definitely a memory leak, not necessarily related to this bug.

I assume that we’re talking of dev 2521, right?

Who knows. Maybe on the invisible UI there were errors piling up :persevere:

:smiley: Maybe your savefile no, but your stonehearth.log file? Although if you had that memory leak, it might be quite big, too.

Ah, the clean snapshot. Don’t ever forget to do it. I painfully know the consequences…

and dont delete it, i painfully know those consequences… :expressionless:


Right it’s happened again and this time no idea what caused it.

Could you upload your stonehearth.log file?

Right will do and also task manager showed up 90%+ memory activity with Stonehearth showing as Not-responding.

stonehearth.log (2.2 MB)
There you go. And just to note, up until I reloaded there was no issue running the game. Trying something new/old did not work thought I knew where I went wrong so reloaded and BANG! Save made the (game) day before works.

1 Like

I have the exact same issue. Sadly I am not allowed to upload any files :frowning:
I uploaded it to GoogleDrive: Stonehearth - Google Drive


1 Like

I just had No UI and hearthling action when I loaded my save file from last night. Early game, little done in terms of mining or building. Should I upload files or do you guys have what you need already?

Edit: Uploading the .log so it isn’t altered when I play again. I’m hanging onto the save file in case it’s wanted/needed. stonehearth.log (46.4 KB)

1 Like

Save files are problematic for uploading to the discourse because of their size. Even a brand new save (zipped) is ~4 MB and the limit on uploads is ~2.5MB.


thanks for the info! i never have tried uploading files to the discourse, so i never really knew that :grimacing:

I kinda figured a file like that would be big for a forum but i’ve seen it discussed in other threads for certain issues. Thought it was worth checking before I delete it :slight_smile:

You can always use a service like GoogleDrive or DropBox though. Pretty sure both of those are free (short of the tedium of signing up).