"Undo" button in the build screen isn't doing anything

The “undo” button often doesn’t do anything in the build screen.

Steps to reproduce (case one):

  1. Place a wooden foundation in the build screen.
  2. Place walls around the foundation.
  3. Click on doors.
  4. Now hit “Undo”. In my game, the walls aren’t being removed.

Steps to reproduce (case two):

  1. Place a wooden foundation on the build screen.
  2. Place another section of wooden foundation to expand the original area.
  3. Remove a portion of the wooden foundation you’ve placed.
  4. Now hit “Undo”. In my game, nothing happens.

Expected Results:
One would reasonably expect “Undo” to work as many times as necessary, taking you back step by step through the entire build until you have an empty build area again.

Actual Results:
In each and every case, hitting “Undo” is doing nothing for me. In order to correct a mistake I’ve made in a build, I have to open the console and use the “destroy” command to remove the building and start afresh.

Version Number and Mods in use:
develop-2996 with no mods

Do you have autosave on? If so, and autosave runs while you’re building, “undo” will only work back to the point of the autosave.

I just tried to repro your issue as described (both cases), and I can undo with no problem.

1 Like

Ahh, I hadn’t tried that. Thanks, Brad. Either way, is that the intended functionality here? I understand the game still has a long way to go, so if it’s not there but will be in future, I’ll leave it at that. :slight_smile:

Also I’m guessing the workaround here is to just build while paused or turn off autosaves while designing?