UI Bug When Merchant Arrives

When a merchant arrives, the UI popup is unpopulated (blank) and an error dialog opens.
F5 to reload the UI fixes the problem, but if you go to messages and try to select the merchant again, same error. This did not occur on my machine in 10.5. (Now running 11.0 / Develop 2477 x64).
Additional info available upon request.


Does this happen for every merchant or was it a single time error? Haven’t played in the newest version yet, but I’ve had this happen to me once before and have heard others having single cases of it as well.

I suspect the hardest part of it for the devs is that it’s very hard to reproduce. Even if you have a save from just before the bug happened, there was no garauntee that it was going to happen again.

1 Like

next time try and take a screenshot, this is also helpfull for others to see what you mean.

1 Like

welcome to the discourse @Neo :smile:

as @Sweeck said, a screenshot would be very helfpful if this happens again. even though your a new user and cant upload it directly to the discourse, i would be able to embed it for you if you upload it to imgur.com or some such place.

here the bug i have :

and if i clik on the right up cross :

and finaly after reset the UI vi F5 key :
develop-2477 (x64)
…nehearth/components/building/building_component.luac:240: assertion failed!
stack traceback:
[C]: ?
[C]: in function ‘assert’
…nehearth/components/building/building_component.luac:240: in function 'load_from_template’
stonehearth/lib/build_util.luac:44: in function 'load_structure_from_template’
stonehearth/lib/build_util.luac:48: in function 'load_all_structures_from_template’
stonehearth/lib/build_util.luac:170: in function ‘restore_template’
…th/services/client/build_editor/template_editor.luac:10: in function ‘_restore_template’
…th/services/client/build_editor/template_editor.luac:15: in function ‘go’
…rvices/client/build_editor/build_editor_service.luac:39: in function <…rvices/client/build_editor/build_editor_service.luac:39>

I post here it is the same problem :

my inventory : 0 ?

Same here, the only way I can see my inventory, is by ‘place item’ dialog. Have you guys maybe tried ‘ib’ console command? Just thinking if it’s a connection or no.