Tools for modding Stonehearth

Hi! I’m messing around with Stonehearth and mixins to see how I can affect the game, and I’m running into an issue reading the .luac files included inside Stonehearth. They are difficult to read as they are, especially considering I’ve got no prior Lua experience (though I’m closely familiar with Javascript, and the two appear to share a lot of similarities). Does anyone use any sort of tool to beautify .luac into something more readable? Note: I’ve tried unluac, UnSmod, unwrp, and LuaFormatter, all posted elsewhere around the forum. None seem to be working right now.

Another question is about modelling. Is Qubicle MindDesk the only software I can use right now to create Stonehearth assets? I’d use it, but I wasn’t able to complete the purchase process – some error about me not being in Europe.

In other words, what is the tool chain everyone uses?

2 Likes

i believe there is another program called “StoneVox” don’t know exactly where though. @honestabelink should be able to help you.

It is not as @8BitCrab has said you can use StoneVox It is 100% free to use you can download it here StoneVox 3D - Community Voxel Modeler for StoneHearth

3 Likes

I must mention that StoneVox is quite a risky program at the moment if you’re planning on animating anything (making objects and re-texturing is okay)

Honest is working on it, but still, keep it in mind

1 Like

Hi @Moai,

I have solutions for both your needs :slight_smile:

Lua unminfier

paging @Tim :slight_smile: . Qubicle Constructor is very very good, I’d recommend it. Perhaps Tim can get this sorted for you :wink: .

You could also go to the Minddesk forum and ask for help there.
http://www.minddesk.com/vanilla/


Alternatively as others have pointed out already,

StoneVox is my voxel modeler for SH.

1 Like

Hey @honestabelink, thank you for getting the ball rolling on StoneVox! I’ve messed around with it a little bit last night, and when I’m comfortable with my coding abilities in Stonehearth, I’ll sit down to create some models (I’m a coder before everything else).

I have tried the Unminifier, but it was showing only a blank screen for me even when I opened a file. :frowning: Maybe I am doing something wrong? I’ll give it a shot again today.

EDIT: Got Unminifier to work. I didn’t realize I was supposed to open an entire SMOD file, rather than single LUAC files. Thank ye kind sir, I am making the utmost use out of your tool.

3 Likes

:open_mouth:

I was not aware of this. Definitely voting for you if you ever run for POTUS! (Or try to, at least!)

3 Likes

All these tools were made back when the lua was compiled, not just minified. There is a new version of unwrp available which can deal lovely with the minifying and works like a charm (much better than its ugly Java equivalent). It is, however, not public.