Teach me how to SMOD

Fixed it!

This makes me happy :joy:. The black circle in the background, less so. Any experience with MagicaVoxel?

1 Like

to turn off the black circle simply disable “GD” in render mode, this turns off the ground so the background is completely transparent.

edit:

here’s a screenshot of what i’m talking about,


the red circled button is what you want to disable.

2 Likes

Yep, worked Perfectly. Thanks for all your help. I’m going to bed now, but I’m afraid there’s a new problem, with the shadows…

This can really only be perfectly viewed by playing the save, but now the world shadows update weird. Like, the game can’t update the shadows fast enough or something. It probably can’t be fixed, and it wasn’t happening before I just got the mod to work.

Edit: I reloaded the game and the shadows are gone, so I removed the save.

It’s supposed to be the “modding API” version number. After a lot of changes in A14 Radiant changed the game’s API version to 2, so all the old mods for version 1 would automatically not load rather than cause errors. Of course, that doesn’t mean mods compatible with, say, A15, are going to automatically compatible as long as Radiant stays checking for mods made for API version 2 or newer.

1 Like

Alright @8BitCrab, I’ve got one more problem. I hope.

That’s not how you hold that Steve!

How do I flip the sword around so that he actually holds it like he is supposed too?

1 Like

with the flip/rotate buttons,

i believe you need to flip it on the “Y” for it to work properly

edit:

you also might want to refer to this guide,

1 Like

Hey it worked! Turns out, not only was the weapon not centered, the point of the sword was at the crosshair. I had to simply drag it across so that the end of the handle was there instead.

That should be it for a little while, at least. I want to add in some 2 handed (Read: 2 swords) weapons. For now though, time to fight some monsters!

OK. Another problem here. This time I know what caused the problem, I just don’t know how to fix it. I just added in another weapon, so i renamed the folder from “RWBY_weapons_mod” to “RWBY_weapons_mod_1_1”. Now, everytime I load my saved game in which my footman already had equipped the first sword when it was “RWBY_weapons_mod”, I get a load of engine errors, 1 about the footman not yeilding after AI spins, A few mention lua errors, and one saying that the game couldnt find the sword in the manifest of “RWBY_weapons_mod”, even though that folder is no longer in the mod folder and has been replaced by the new one.

I’m assuming the errors come from the footman suddenly not having the weapon he was supposed to, because it references the weapon as coming from the old file path. Is there anyway I can get around this, and update what the game is now supposed to look for?

Added sweet pic for spoilers. Not related to problem.

Edit: I guess what I’m asking is “How does one do version compatibility?”

I’d say the best way is to just Not Change the name of the mod

You can name them ‘version what what’ in post but having the name for the fime itself be consistent would be my suggestion sice i do it myself and add numbers to backup files and old resions instead of the latest release

Edit : also i love the RWBY weapons bolth in the cartoon and in the mod of yours

3 Likes

Ok. I realized last night while I was sleeping that that was probably the best thing to do. Thanks for for liking the model.

Houston, we have a problem. I just made Ruby’s Scythe, but it would seem the iconic form is broken! When carrying the weapon to the stockpile, the blacksmith had nothing in her hands, and now that the sword is in the stockpile…

The footmen are not picking it up and equipping it, nor does it appear to be visible anywhere in the stockpile.

I tried making a separate model to be the iconic model, but it didn’t seem to work. I don’t have any errors or anything though. I ran all my JSON through JSONlint, and all appeared to be in order.

Help? What do you do @8BitCrab when you need a specific icon model?

umm… i had this happen with Armory Expansion, in the end it was something to do with the iconic.json not having the correct file path or something like that…

so i would say double check your file paths for all of the scythes .jsons (not just the iconic one) also make sure to check the .log file to see if it has anything to say about it.

1 Like

Silly me. I spelled it as Sycthe in my saved models, but as Scythe everywhere else!:confounded:

2 Likes

well i’m glad it was just a file name/path that was wrong, would have been a pain to track it down otherwise…

Yep. It’s funny, I knew that that “cy” would be the death of me somewhere.

1 Like

I like your Scythe but not his red color :wink:

@LaGrosseChoco
It’s colored like that because it’s modeled after this!
[URL=http://s1279.photobucket.com/user/Tatsutetsu/media/RWBY%20Crescent%20Rose/Reference_zps3a0cab6b.jpg.html][/URL]

1 Like

Which comes from this…

http://www.ringoame.notcliche.com/wp-content/uploads/2013/05/red6.gif

I am haveing the same problem changing it back to a .smod from a .zip

How so? Can you just not see the .zip file extension?