Suddenly constant crashing and failure to launch

Hey, I have hundreds of hours in ACE and been a long time lurker on these forums.

I’m aware of the openssl dlls for /64bit etc and had been using them with no problems for years.

All a sudden, sometime in the last month (since i played last) the game no longer launches 9 times out of 10 and if it does lauch, will crash without feedback to desktop after a few mins.

I’ve changed nothing on my computer, not updated any drivers, nor tinkered with stonehearth.

The only thing I can see that’s changed were a couple steam workshop mods updated “fishing” and “ACE” from what I can tell…

I’ve verified data via steam, uninstalled, reinstalled, reinstalled openSSL - nothing works

Any suggestions?! xD

Could you share your log right after one of those crashes?

You can find the log on the game folder, it’s called stonehearth.log

Hoi, Thanks for the reply - log attached
stonehearth.log (129.6 KB)

Anything nefarious in the log?

Just to add, I’ve tried running the 32bit version of the game and it’s running fine.
I’m guessing its something to do with openSSL …

Just done another fresh install of the game and re downloaded the workshop mods (ace etc)
grabbed the openSSL files from the post over here - Problem starting the game - #2 by DaniAngione and still no dice…

Game launches, music starts playing … stutters a bit then dumps to desktop with no feedback
Heres the log from the most recent attempt - stonehearth.log (129.1 KB)

Really at a loss here… after 700hrs with the game, can I no longer play it? :cry:

So spent a few hours trying various things, like running as admin and compatibility modes with some small degree of success. It would run without crashing using win7/8 compatibilities, but it would run awfully (like 20% of what it would normally) long load times and fps drop in game etc…

Giving up on that, I started enabling and disabling mods one at a time to see if that had any effect and low and behold, it runs every time and amazingly when I disable ACE!! :frowning:

I popped on the discord and grabbed the experimental branch to see if that would work any better and it went straight back to crashing.

So for now I’ve removed it again, but I really like ACE and don’t want to play without it lol HALP!


So I went and grabbed ‘openssl-1.0.2u-64_86-win64’ and ‘Disabled fullscreen optimizations’ on the Stonehearth.exe in the /x64 folder - back on 165fps, running ACE and and handful of other mods, yay!

I’ll mark this as the solution for now in case anyone else finds themselves in a similar situation - happy gaming!