Stonehearth isn't launching!


#1

Hey all!

I’ve been trying to launch/run my Stonehearth beta for a few days now, and it’s being really problematic. I have my humble bundle key, I’ve downloaded the Stonehearth alpha launcher from the humble bundle page, installed it on steam, and yet it still doesn’t work! I double click on the icon that appears after I run the installer - nothing happens. I click “play” on the steam page, and I get a flash of a little box that says “Preparing to launch Stonehearth” - again, nothing happens.

When Stonehearth beta first came out, it worked fine, save for the in game bugs. I think what might have messed things up was me updating this pc to windows 8.1. Would that have any effect?

Any help would be much appreciated, as I’m really keen to get playing!


#2

Updating to Win8.1 not only shouldn’t have an effect, but when I updated my PC to it I had no issues, so it shouldn’t be that…

First thing to check would be that your drivers are up to date. If they’re not, then they need to be! :smile:

Have you checked the log file to see what that says? Does it show any signs of the game opening at all?


#3

Thanks for the quick answer!

Whenever I launch there is not even a hint of a log file, much less any sign that the game is actually launching.

My drivers, however, might be the problem. Would all of my drivers have an impact, or perhaps just video, for example?


#4

Video drivers are often the problem in this case.

But you should keep all your drivers up-to-date, not only your gpu.
Just like using old tyres on your car, they may still work somehow but you are taking unnecessary risks and using more fuel than needed.


#5

Sure thing Neko, makes sense. Could you recommend how I should update my drivers? I know for certain that my graphics card is an Ati Radeon.

Most places I go to offer a software download, which scans your computer and tells you which drivers need fixing. Apparently they then go to make you register and pay money to get the software. Any idea how I could update without paying?


#6

hey there @Rollener… welcome aboard! :smile:

in addition to making sure all your drivers are up to date, could you also list out your system specs?

  • video card
  • CPU
  • memory

as a test, have you tried launching SH as an admin?


#7

Sure @SteveAdamo, here they are!

video card - Ati Radeon HD 4800 Series (Microsoft Corporation - WDDM v1.1)
CPU - Not EXACTLY sure what this is, I’m not very techno-savvy, however the processor is - Intel® Core™2 Quad CPU Q9550 @ 2.83GHz 2.83GHz.
memory - 8.00GB (3.25 GB usable)

Hopefully that all makes sense!


#8

yes sir… thanks… your machine is certainly capable of running the client…

as suggested by @not_owen_wilson here, I wonder if perhaps you could take a look at the suggestions here, and see if changing the permissions under which you run SH will make a difference…


#9

Awesome, thanks @SteveAdamo!

Edit: I went and looked at the links you sent me, and I kinda get what @Amerisun is saying, but I’m not 100% sure what I can try to do to fix my problem. I navigated to the AppData/Roamin/Microsoft/Crypto/RSA folder, looked inside there and there are 9 system files, but no folders. I was going to just rage delete them all, but I get the feeling that might not be such a good idea. Any ideas as to what I should do?


#10

Go to the official AMD website for graphic driver. Others are just spam.
http://support.amd.com/en-us/download


#11

I am significantly less tech savvy than all the folks prior but… have you tried running this as admin?


#12

The new version of Stonehearth on steam right now (unstable release) contains a fix for the crypto stuff, so see if that doesn’t fix your issue. (It’ll be on Steam stable channel in probably a week or so).