Steam Latest Build Won't Launch Game

Ever since branch 156, I haven’t been able to launch the game.
If I switch the beta settings to “opt-out”, it will download the right data and launch the game, yet opting-in for the beta won’t let the game launch.
I click play, the small steam window shows up that says “Preparing to launch Stonehearth”, but that closes and never loads the game. I’ve checked the application logs in event viewer and nothing shows up…

Any suggestions? Should I just wait for the next build to get pushed?

Do you have any mods? I know Candledark causes this…

1 Like

No I don’t. Purely whatever steam installs. I thought maybe it could be an antivirus thing, so I tried disabling that, but no avail. :frowning: I’ve also tried deleting the local content and re-downloading the whole game, twice. No luck.

Could you post your system specs? Do you even get to the black screen where the logo of Radiant should appear?

I don’t get that screen. It’s as I said, I get the steam “preparing to launch” window, then it disappears. When I launched it this morning I had an update queued for download for a different game. I interrupted the update by trying to launch stonehearth to see how it would react, and the update halted while Stonehearth tried to run, but the launcher window closed and resumed my other update as if it just killed the stonehearth process.

Processor: Intel Core i-4770 @ 3.40 GHz
Graphics: Geforce GTX 770
Storage: 1TB (about 1/2 free)

Attached is my dxdiag file for in-depth detail.

Axidion-DxDiag.txt (28.6 KB)

This is a weird issue. Were you able to play the previous version? The first Alpha 6 that was released (not the r156, that’s the next day patch).

Also, what is your OS?

Can you try to run Stonehearth manually, by going to the folder where the game is, and launching it there?

Okay so I just checked the stonehearth log, it’s actually totally my fault. Once upon a time, I purchased cubicle and wanted to look into mods. So I made a shortcut to the mods folder on my desktop. Apparently, even though I used steam to “delete local content” some stuff still remained in that folder (probably because of my shortcut). It’s now working. My bad! Sorry for any headaches I caused. I went through and manually deleted everything from within windows instead of steam and reinstalled. All is well and I can play the game. I really should have just checked that stonehearth log first @_@…

stonehearth.log (1.1 KB)


Pretty sure it’s not you, it’s Steam. For whatever reason, it likes leaving a few files & folders behind when it “deletes” local content, and not just for Stonehearth.

1 Like

Ok, I’m glad we got this resolved :smile:

I actually have a problem too when i try running or opening HearthStone.exe it fails to launch here are my Computer specs and my HearthStone.log file :

Computer specs :

Processor: Intel® Core™2 Quad CPU Q6600 @ 2.40GHz

Intalled memory (RAM) : 5.00 (4.87 Gb usable)

System type : 64-bit Operating System, 64 Based processor

And i got Pen support

Now for the HearthStone.log file…

2014-Nov-26 15:35:56.895913logger initialized
2014-Nov-26 15:35:56.897913 | server | 1 | app | Stonehearth Version
2014-Nov-26 15:35:56.930909 | server | 0 | | lua git is enabled
2014-Nov-26 15:35:56.931915 | server | 1 | app | Running Stonehearth server on port 33490

Did you try doing what I did? Navigate to where the stonehearth folder is in windows and delete it along with all of its contents, then re-install.

it didn’t work :confused: sadly…

Did you try any of these things?

90% of times, people got resolved this kind of problem just by updating their graphic drivers from their corresponding manufacturer’s website.

Do you play by Steam? Some people mention that they have several Stonehearth folders, but I think that’s with the Humble Bundle install…