Square peg should fit in a square hole..right?


i can build this house step by step in a 13x11 sized hole one deep, with a single pixel hole attached in the middle of the long end. extra little hole for the chimnee start)
BUT i cant put the template into a simmilarly sized hole. this should probably get fixed. that or enable the manual adjustment of an entire template, like dragging rooms around.

Steps to reproduce:

  1. dig 11x13 sized hole, one deep in the floor, dig 1x1 sized hole attached on the 7th pixed of the long end of said hole so you get a huge hammer with a microscoping handle-shape.
  2. try to put the template in.

example buildings.rar (87.7 KB)

tried removing the little extra block for the fire place too (thats the mkII)
still no jazz

Additional info: I’ve found that sometimes the game will allow you to do this… But only in one allignment.
So the blueprint has to probably face the original compass direction.
Even though the shape of the hole is correct in any other orientation.
So the workaround would be to make a floor plan that’s symmetrical in four directions for now, and build the top of it seperate. B

What this means is there is something off about the rotation of stored blueprints

1 Like