Settling Under a Rock Not Recommended


#1

Title: Yeah, don’t place your starting flag inside the rocks.

Summary: So I was trying to find a different bug when I decided, hey lets place the settlement in a rock! That’s right, one of the larger spawned rocks that you find frequented around the landscape was the one in which I placed my camp. The game then went irresponsive to commands (though moving the camera worked with a slight delay) for about 3 minutes and when I thought I might have killed it, sure enough the camp placed. About 500 blocks away.

Steps to reproduce:

  1. Start a new game
  2. Find some of the little boulders that are spawned
  3. Place your starting flag and fireplace in it
  4. Wait a bit, then witness where the game spits you out :slight_smile:

Expected Results: Not sure? Probably that you can’t place your starting flag there tbh, but I’d at least expect it to place inside it or crash and not place at all, not just spawn it in a random location.

Actual Results: Spawned ~500 blocks away from the rock.

Notes: :smile:

Attachments:


I found the rock I tried to spawn in and selected it, in the bottom left. The light you can see in the top right is where the campfire is. I am unable to zoom out enough to actually quite fit it all in. :slight_smile:

Versions and Mods: Alpha 3 Latest Release, no mods

System Information:

  • Acer Aspire E1-571
  • i5-3230M 2.6GHz
  • Intel HD Graphics 4000
  • 4 GB RAM