I am on hard mode with most of my hearthlings being damage dealers. Whenever I am raided by Kobolds, my troops never respond to any commands directed onto the Kobold Archers. They will instead either run away and back off to a previous defend position, or stand still and take damage. The only way my damage dealers will attack is when I plant a defend flag nearby the Kobolds, and they always run away when my troops get close so I have to keep on moving the defend flag. This is especially frustrating because I use all four parties for different crowd control.

can’t you use the attack flag?

not sure this is really a bug, as the defend flags sound as though they are working how they should, your guys will only go a certain distance from them before going back. as @theFipmip said, try using the attack flag instead.

As I can understand it is the problem he is facing. His troops won’t recognise kobolts as targets, and go away/won’t obey, unless he use defence flag, so they hold position near by and get the agro. (I’ve the same problem but only with archers)

1 Like

i think it’s the bug where the defend flag refuses to be overridden by other commands. albert said it’s fixed for the next patch so until then just use the attack and move flags :slight_smile:

1 Like

Attack and Move Flags Don’t work
I’d say @henrique_neto pretty much nailed it.

1 Like

alright, i’m going to say it’s the bug @jjjshab mentioned, i guess we’ll have to wait and see when that bug fix is released… but i’m really tired right now so there actually might be an obvious answer/solution, i’ll check this out again in the morning…

I dont really think it’s the attack/defend flag, just noticed this myself in my own game. The archer will not attack the Kobold archer in a 1v1 fight.
He will simply stand there and take a defensive position, moving ever so slightly backwards.
My guess is that it has something to do with the range increases, as archers will generally try to keep their max range (from what I can tell) and since the Kobold has a shorter max range it will attack at a closer range than your own archer(s), forcing your archer to move away for range.

I think what happen to him is the bug report I posted with switching from defend flag to attack flag without canceling the defend flag.
What will happens is that the defend flag get glitched and is now invisible the only way to make your troops move to a different location is by defending another place and then canceling it.

1 Like

Not sure if this is related or not, but sometimes my fighters act strangely when I sent them somewhere. I will send my party of footmen/archers/etc to attack somewhere and they will either not go all the way where I want them to, or they run off in a different direction altogether. It seems to only affect the attack command flag, placed on the ground or directly on a mob. If I use the move to flag instead they go where I want just fine. If I had to make a guess I’d say it’s a bug in the leashing code. They seem to get a little bit buggy the farther away they are from my town/banner.

Has this happened after you’ve already used the defend flag?

It happened to me where I used the defend flag once and it broke every other command. I can’t remember if I started a new game or if I save/loaded to fix it, but I haven’t used the defend flag since and everything has been pretty good

Also facing a similar problem here, although not convinced it is just the defend flag bug. When a group of enemies appear I find my tiny army will happily kill the melee attackers when sent to a different location with the move command, but completely ignore the archers and healers. If this were the defend flag bug, wouldn’t they ignore all attackers? Occasionally my archer will be the only one to notice that there are more enemies, making me think it also has something to do with ranges. I’ve noticed as well that after a reload the notification for ‘enemy found’ pops up anew, even though they are theoretically part of the same band of attackers, not sure if that may be relevant.

Having said that, a quick save and reload has always solved the problem for me, so I am happy to wait and see whether the problem persists after the incoming fix.

Adding @albert. I know he’s looking at all this stuff right now.