Scholar Mod 1.1.2.1 - Revived! (Semi-transparent features fixed)


#62

I found out the problem that is causing the bug. It seems at least one or more of the files/coding changing is the reason for the bug.

  1. start_menu.js (not .json)
  2. App.stonehearthClient.openCrafterMenu
  3. something else that’s related to these two

However, I got no solution yet. To be frankly, if #2 is the reason, I don’t think I can solve it. If anyone got some more clues for solution, that would be awesome.


#63

@fantasyworm you can try to contact @The_M he has added a crafter class(the gardener) and it successfully works in A18(last i checked).

Or you can just look in the files an see the differences.


I’d go through and try to tell the differences between the two but I’m busy right now, I can look at it later tonight if you still haven’t solved.

Look at the difference between the gardener.lua and gardener_description.json and the scholar’s.


#64

I actually checked it and I found no difference between the two mods. Mine also worked A18 3107 but got the bug report after the UI Improvement update.

I think the bug was created because while Improving the UI, some codes have changed and it’s interrupting the procedure of menu_action, show_crafter_ui when opening the crafting menu for mod jobs. The thing is that I can’t find the direct cause. I even tried modifying the stonehearth.smod only for finding the cause, but nothing I expected was the problem. These are the ones I tried and found out.

  1. checking the job and the button itself is working well. (The tooltip is working well when pressing the activated button.)
  2. fixed start_menu.js’s component to the A17 version - no change
  3. fixed citizens.js’s component to the A17 version - no change
  4. tried “show_crafter_ui” to “stonehearth:show_crafter_ui” - no change
  5. simplify the scholar.lua like gardener.lua - no change
  6. No difference between the two version of App.stonehearthClient.openCrafterMenu (it’s found in \Stonehearth\mods\stonehearth\stonehearth\ui\root\js\stonehearth\stonehearth_client.js)
  7. Difference found between the two version:
  • start_menu.js
  • show_team_workshop.js
  • citizens.js

If anyone finds the clue to solution, please help me.


#65

I’m looking into it.


I have noticed if you go to the workbench button on the bottom, the Scholar workbench does not appear at all.

Could be linked to the problem as to why it doesn’t open through any means


#66

I think on the scholar_workbench.json you have a wrong job_alias, it says “stonehearth:jobs:scholar” and it should be “scholar_mod:jobs:scholar”.

However this still doesn’t fix the problem :sweat:


#67

Thanks for checking it out. No, that doesn’t fix the problem, but it still needed a fix.

Well… This will stay broken for a while, but I’ll fix it after this week. (I’ll be travelling Tokyo.)


#68

I tried a lot of things like that last night.
There are a lot of places where it was “Stonehearth:jobs:scholar” instead of “Scholar_mod:jobs:scholar”.
But none of them seemed to fix the problem.

The sound for a workbench opening doesn’t even play when clicking the button, so I don’t know what’s rong.

If the Scholar workbench is a recognized work bench shouldn’t it appear on the work bench tab?


#69

I declare temporarily abandoning the mod.

Since this mod is stuck in some kind of file corruption(my guess), it would be better just abandoning the mod and letting others check out the stuffs they need(such as semi-transparent entities, rune plate, obelisks).

※ Never directly copy the files from the mod! It can corrupt your mod!

Meanwhile, I’ll just try to make other mods or try to make an indie game.

I somehow hope that at least this mod is useful for the reference.

PS: Then again, I will be really glad if you ever find out some coding error then share it with me.


#70

THE SCHOLAR MOD IS BACK ALIVE!!!

I finally found out the cause of the malfunction!
It seems that the semi-transparent feature was the cause.

I dunno why that’s malfunctioning but I temporarily got rid of the recipes for awhile so the mod still can be played.

In the meantime, I will be glad for some help about actually fixing the bug. I have looked the bug part, but coundn’t find the way to solve it other than getting rid of it. The 4 Items are the cause.

Blue Glass Window Frame
Red Glass Window Frame
Green Glass Window Frame
Latticed Glass Window Frame

This is the whole part of the blue_glass_window_frame_ghost.json.

{
“mixins”: “stonehearth:mixins:placed_object”,
“type”: “entity”,
“components”: {
“mob”: {
“align_to_grid”: [
“x”
]
},
“model_variants”: {
“default”: {
“models”: [
“file(blue_glass_window_frame.qb)”
]
}
},
“render_info” : {
“color_map”: “scholar_mod:color_map:translucent”,
“material_maps”: [
“/scholar_mod/data/materials/material_maps/translucent_material_map.json”,
]
},
“stonehearth:fixture”: {
“cursor”: “stonehearth:cursors:create_window”,
“margin”: {
“left”: 0,
“right”: 0,
“top”: 1,
“bottom”: 1
},
“bounds”: {
“min”: { “x”: -1, “y”: 0 },
“max”: { “x”: 1, “y”: 2 }
}
},
“stonehearth:portal”: {
“cutter”: [
{
“min”: { “x”: -1, “y”: 0 },
“max”: { “x”: 1, “y”: 2 }
}
]
}
},
“entity_data”: {
“stonehearth:catalog”: {
“display_name”: “i18n(scholar_mod:entities.construction.blue_glass_window_frame.blue_glass_window_frame_ghost.display_name)”,
“description”: “i18n(scholar_mod:entities.construction.blue_glass_window_frame.blue_glass_window_frame_ghost.description)”,
“icon”: “file(blue_glass_window_frame.png)”,
“category”: “window”,
“material_tags”: “clay portal crafted window stockpile_portal”
}
}
}


#71

There’s an extra comma at the end of that Line :merry:


#72

And that’s why if your code is failing for no reason you should always paste it at http://jsonlint.com/


#73

Funny enough, that’s exactly what I did. Really handy site.


#74

I have fix the window frame problem for the mod and thelegorebel is right. The comma is the error in the mod. fantasyworm place using the http://jsonlint.com/ to check the error.


#75

Since I am not the mod creator and I am a new user. I do not upload the fixed mod to the site.


#76

that is the window frame after fix. and the red one still need some work look like.


#77

I fixed the problems about the windows and also the alchembrazier effect issue. Since to be honest, I have abandoned the mod for some time, I will add just add more simple transparent features later on and for a while.


#78

Hey i Wanted to ask if this mod works with Alpha 21
I wanted to use it but saddly it didnt work
i would love to play it so please could you make it work for that version


#80

Will you Upload this mod to the Steam Workshop?
Would be really nice