Does the mod name("_") effect the mod working?

I’m checking the workbench bug of the Scholar mod, I just can’t find the reason why the workbench UI of the Scholar is not working. The only specific difference I found is the mod name.

While other mods do not have “", mine have "”. Perhaps this is the reason? I will try Changing “scholar_mod” to “scholarmod”, but would it work?

rayya’s mod has underlines _ too.

Oh yeah… Ok then that’s not the problem…:cry:

Then again… This is the only difference I found among crafter job adding mods. I will at least give this a try.

I checked your mod last time you asked for help. Like you, I couldn’t find something wrong in it…
Although I didn’t tried adding logs to it. Do you know how to log? So you can check in the stonehearth.log what is going on. I normally add some “flags” just to know if the game at least reached the code I’m working on.

I might have found a problem.

Managed to fix this… but still doesn’t open the workshop

Okay, so I started adding in the scholar slowly and was going to see what caused it to break, but I’m really busy…

I have gotten it the stage where it opens and shows the 2 workbenches tho :smile: (137.7 KB)

IF you wanna try to slowly add in all the stuff again here’s the set-up I have it as of now.

I also changed the name from scholar_mod to scholar just to know what’s new and what still needs to be looked at.

1 Like

One thing to test (it just happened to me…) check if your code has invalid characters. I had copied some characters from a .pdf and some of the spaces are not real spaces, then it ends up ruining everything.
In my case it gave errors, I don’t know if it can fail because of bad text characters without giving errors.
Just worth mentioning anyway, as this is making no sense to why it is not working.

1 Like

Umm… If that’s true I think there’s 2 possibilities.

  1. Since I’m Korean and using Korean Typing, maybe some problem happened from there. Although I think it’s highly unlikely because when I used the other dev tools, there was no such problems.

  2. I use Tab keys. Maybe that’s the problem…

Anyway many thanks for the advice, I will try again to fix it.

Ok… now that’s great! Hmm… I will try changing your ‘scholar’ file to 'scholar_mod to check my hypothesis!

… and that was not such a smart idea. It seems that “_” does not have anything with the problem.

Just test your code at it will warn you which line has problems if that’s the case.

I remember you also use notepad++ right? If that is the case check the file format too, at least within webdesign, that gave me a lot of problems. Sometimes the files were in ascii, sometimes in utf…

1 Like

Sorry for interrupting, but can you tell me where you got the invalid characters? I’m having trouble finding it. Maybe it’s because the encoding keeps showing as ‘Korean’, not ‘UTF 8’ or stuff…

The error I got from copying a pdf was invalid space characters (we see a space, but for the computer it is something else), sometimes we also get wrong quotes (there is the common “code” quotes and there is a fancy quote, not valid for json)

Note: this was not in your mod, was my experience in other projects. I’m just throwing ideas of what to test.

Oh Ok, thanks for the tips! I’m look up the older version of my mod, to see if the change before was ok…