Roof UX and settings not working as it's supposed to be

When modifying the settings for the roof on the new building (with a build-from-scratch build of course), the UX doesn’t change at all, but on the back, the changes make effect ONLY ONCE.

roof with the default settings when selecting roof option

front slope option unselected (UX remains the same, but setting applies), if you try to select the front option again to turn it on, it will not make the setting change. and this happens with every option

This is with all the options clicked, and after that it’s keeps the same until you load the save again, after the load the settings will go back again as the UX displays

Steps to reproduce:

  1. Change anything on the UX and you’ll notice that the UX remains the same.
  2. Place the roof and the settings will apply, but if you try to select the option again, it will not make any change after the first change.

Expected Results:
UX displaying the settings checkboxes propertly and the roof placed accordingly to the settings selected
Actual Results:
UX doesn’t change at all and the settings only applies once.

Version Number and Mods in use:
Alpha 24 Test Versión (unstable Branch)


Ping for @jamiltron!

1 Like

Thanks for the report, I’ll check this out later today.

i think it happens if you try to change the settings just after you put the roof.
if you reselect the roof and modify it then the UI should show the changes propperly

but still, it’s supposed to work without any tricks or similar though.

And i tried to reselect the roof option many times before placing a roof or changing their settings, but still it happens the same result (8

right, it only works propperly when you change the settings after you place the roof and reselected it.
before or just after placing it it fails.

1 Like

Yep, only Works if you place the roof and you use the pointer option and select the already placed roof, but the UX and settings on the roof option is broken

The roof UX and settings broken with the roof option

The pointer option triggering the roof option working fine

So as far as we can see, the main issue is only the roof option UX and settings, for now for roof settings the pointer option will have to be used after placing a roof, but not before with the roof option.

Thanks @No_Name for replying on how to edit the roof, i didn’t know at all that way to edit the roof (8