[Res] [r1665 Unstable] Crash on start with Vista

resolved

#1

Just updated to b1658, the game will not open. I get a “Stonehearth has stopped working” notification. I’ve deleted local game content, reinstalled, same issue.

I clicked on the info box as well (if it helps):

My Specs:
Intel Core 2 Duo T5800, 2.00GHz
4.00 GB RAM
NVIDIA GeForce 9600M GS
Vista


Poor things, but hey they're fine
Crash on start up
#2

Same error here. I can confirm this.
“The procedure entry point K32GetProcessMemoryInfo could not be located in the dynamic link library KERNEL32.dll”

I think it’s translated like that :confused:


#3

Cannot reproduce here - I just downloaded it via Steam upon seeing this thread, and all is working fine :confused:


#4

Don’t say that… I expected this release to break the game for my computer, but it’s worse than I thought, I also have Vista as @phector2004 :

Windows Vista Home Premium SP2 (32-bit OS)
Intel® Core™2 Duo CPU P8400
2.26 GHz 2.27GHz
RAM 3GB
Mobile Intel 4 Series Express Chipset Family

Now I’m really really worried…


#5

Can confirm that as an 8.1 x64 user, I have no issues with the latest build.


#6

Is there anything new in the latest build? Or just bug-fixing and optimizations?
Edit: Never mind, I’ve just seen the update post.


#7

ok, so we need some additional Win8 folks and a few Win7 to toss in their results… I’m stuck on my phone at the moment…


#8

When I try to debug or tell Windows to give me more details, it says something about an unhandled win32 exception in Stonehearth.exe [6856]
Could it be related? Can some dev check it?


#9

Oh poop… Might have to actually get work done this weekend!
(And also go on that date :stuck_out_tongue: )

With regards to the crashing, could it also be a laptop issue? Devs?


#10

Why would it be specific to laptops per se? In general, laptop hardware is very similar to PC hardware - just not as powerful, due to volume/weight/heat issues.


#11

No idea, really… these computer boxes are like magic to me!


#12

No problem running the game

Specs:
Windows 7 64bit SP1
Intel i7 4790k
RAM: 8gb
GFX: Nvidia GTX 760


#13

I downloaded the latest version of Stoneheath on steam. (Unstable Version) It worked perfectly before now it crash’s when I try to start it up.


#14

Could you be in a similar situation to @Cladox?

If so, the AMD driver site may help :slight_smile: .


#15

I don’t use AMD I use intel and all drivers are up to date.


#16

Also I can’t even start-up the game.


#17

AMD are behind the Radeon graphics cards though, which is why I linked their site :slight_smile: . Also, their update software doesn’t always like keeping the graphics card drivers fully up to date, so if you use a Radeon you may want to check anyway :wink: .

Anyway, assuming it’s not that for the moment… hmm. Some info on your version of Stonehearth (see bottom left corner of the main menu, be sure to include the revision/build number too - latest is 1658) & Windows, CPU, RAM and graphics card may offer some clues, although the fact that it could run before is puzzling. Have you tried a clean install (ie, making sure the folder below is deleted)?

C:\Program Files\Steam\SteamApps\common\Stonehearth

Obviously Steam may not be installed in C:\Program Files, but the rest of the directory structure is accurate for Stonehearth. Anyway, if you uninstall Stonehearth, delete the Stonehearth folder in your SteamApps\common folder, and re-install using the latest update (right-click Stonehearth in Steam, go to Properties, then Betas, then choose the latest option), does that help at all?

Edit: I know you’re using the unstable / latest version already, just want to make absolutely positive that it’s installed cleanly after a full uninstall :wink: .


#18

When you say can’t even start up the game, do you mean from the main menu or from the desktop?


#19

@Silas, Both

@Teleros: NVIDIA GeFore 9800m GS 512 MB, Intel Pentium 2, 2.13 GHz Dual Core, 4GB Ram Windows Vista. (Latest Version, meaning w/e steam allows me to install.)


#20

Thanks for that :slight_smile: . Your graphics card seems like it ought to handle the game okay, and heck the fact that you were running it before now means most of your system ought to be fine still :confused: .

Thinking at this point that it might be worth paging @not_owen_wilson or @sdee (devs, as opposed to us mere fans ^^ ) to see if he can shed any light on this. It certainly sounds like something’s changed at the Stonehearth end, and @not_owen_wilson’s probably the best person to shed light on what’s going on.