[Res] Game has been freezing since first download

Try running as Administrator, may have to create a link external of Steam.

Thank you for your reply. Just did and the same thing occured again: Frozen and does not react anymore :frowning:

Edit: I am not going to post the logfile again, it is exactly the same as both of the logs before

I’m going to suggest doing a file check. Maybe even a reinstall.

I have reinstalled the game multiple times already (last time today). I have removed all local files via Steam and checked if there were any left (there were none).

You’ve opted in for the Beta content right? Otherwise I’m at a loss.

I pledged for the following reward on KS:
SETTLER TIER, BETA BACKER - All rewards from the lower tiers, plus early access to the game through a digital download of the beta, with free updates all the way through the game’s final release! Plus you’llget access to our beta-backer forum to give early feedback on the game, and a special thanks in the game’s credits. We’ll also throw in a CUDDLY KITTEN who will accompany your settlers each time you start a new game. He no good in a fight, but gosh he’s cute!

(plus the Buddy Backer Tier so I will have three copies when its ready)

Is this not qualified for the Alpha? (Well it says Beta, but why did I get a link for Alpha Download then?)

If you have a key you are good, inside the Steam

Stonehearth -> Right Click -> Properties -> Betas Tab -> “Select the Beta You would like to opt into” -> Latest

I can’t remember getting a key as such, but I can subscribe to the “latest”-Beta using the way you just described
(maybe I have just forgotten getting the key. As I said before: It has been quite some time)

Nah, I meant the Steam key for the game in general.

Now that you are set to latest it should get the weekly incremental builds as they come out. Hopefully this will fix your issues if not now then soon.

Ah yes, got one of those :wink:
I hope so but since it is a problem that persists for… about a year now? … I am not very confident. And considering the other bug reports here I seem to be the only one having those problems

Interesting. From my super limited knowledge… It looks like some kind of connection issue. Ummm…

Try running the game offline. Like, disconnect from teh interwebs completely.

Make sure your firewalls and AV programs are turned off, or at the bare minimum have an exception for the game in them.

Ummm…

Im really bad, but the only thing that I can figure its doing is trying to run the client-server stuff and thats causing it to hang because its not connecting? Thats my (poor) guess, but try those couple of things and get back to us.

1 Like

Well, lets try something crazy like turning off your Firewall or turning off your virus scan

@bernie - Thanks for being a backer and welcome to the forum! The errors you posted from the log are normal. I probably need to see the entire log file to determine what’s going wrong.

3 Likes

I like this response. Probably more than I should.

I will happily upload the logfile, but I cannot upload files as I am a new user. Any mail to submit it to?
As a programmer I love your response about the errors being normal :smiley:

Btw: I would have thought the server is a local server (like a server for delivering data in the background like Minecraft does). Still I have tried killing all of teh interwebs, killing my firewall, not using any AV anyway. Same problem

Never hurts to try.

You can probably pastebin the logfile, would be the easiest way I think.

Great idea, here you go:
http://pastebin.com/5LkKMnvR
It’s not too large anyway, since it only runs for about 2 minutes :wink:
Edit: This was the “no interwebz” test run, by the way

2 Likes

Are your graphic drivers up-to-date? Here you can check them Download Drivers

It could also be crashing due to any of these programs:

Because you can actually run the game, but it crashes after some minutes. Although Albert will know for sure, now that we have the entire log =)

Hi I am sorry to say that this seems to have been my fault all along: While I had the newest driver installed for my GPU there were newer drivers for AMD cards in general (I’m using a Gigabyte HD7970 GHz Edition which had it’s own driver branch). When I installed it everything worked great.
Never had problems with other games, but here it seems to have been a problem.
The game runs great now (besides some performance issues, but these are absolutely acceptable for the games’ state) and is really addicting. Had to force myself to stop for writing this post :smile:
Thank you for your great help and sorry to have bothered you with I problem I have caused myself

4 Likes

No worries @bernie :smile:
We’re glad you got it finally working, and that you took the time to tell us. Have fun with the game!