Game freezes when starting? (Alpha 6)

As the title says, I can’t get the game to run whenever I start it. I’ve just bought the game, and I’ve installed it on steam. Whenever I load the game, the window will open, but before any graphics or sound even load, it stops responding and never seems to load up, just displays a white screen forever.

I’ve uninstalled the game and reinstalled it several times (Both on steam and downloading the files on the humble bundle website), I’ve updated my graphics drivers, I’ve restarted my computer, but nothing seems to have helped at all.

I’m running windows 8.1 64-bit, an asus x750j laptop. Intel HD Graphics 4600 and NVIDIA GeForce GT 740M for graphics.

Anyone have any idea what might be causing my problems or how I can fix them?

Hmm, I know @not_owen_wilson was reviously having issues with integrated Intel chipsets. Are you able to choose the NVIDIA card to run the game with?

I know with my laptop I can simply right click the decktop icon of the game and choose the graphics processor - you might need to use the humble version for this, not sure.


No luck. I’ve attempted to run the game with both the default graphics and the NVIDIA processor, and it gives the exact same result each time

Mmm… You’ve tried most of the workarounds that usually fix these problems…

You could try disabling fullscreen in the user_settings file, but I don’t think that’s the problem.

Did you get any information in the event log of your system?

1 Like

The game actually launches in windowed mode by default. I edited my stonehearth json to change “enable_fullscreen”: false, to true. The game does the same crash in both windowed and fullscreen mode though

There’s no setting to do that in my user_settings file. The only thing in my user_settings file is a “user_id” section in brackets. stonehearth.json has a renderer section though, with a section for fullscreen.

Am I missing something from my user settings file that could be causing my problems? And how to I see the event log? Is that the stonehearth.log file?

No, by event log I meant [this][1]. The stonehearth.log file would be useful too, but as you didn’t get to enter the game, I don’t think it will have anything written in it (check it just in case, it’s a text file after all).

Concerning user_settings file, I’m not sure if it has only the user id at the beginning, but it usually has more things inside it, such as:

"user_id" : "f2311246-2d5b-41b3-a1d3-01032ec8207f",
"collect_analytics" : true,
"renderer" : {
	"enable_ssao" : false,
	"enable_shadows" : false,
	"msaa_samples" : 0,
	"shadow_resolution" : 256,
	"enable_vsync" : true,
	"enable_fullscreen" : false,
	"screen_width" : 1174,
	"screen_height" : 640,
	"draw_distance" : 1000,
	"last_window_x" : 87,
	"last_window_y" : 65,
	"use_fast_hilite" : false,
	"last_screen_x" : 103,
	"last_screen_y" : 121
"hide_help" : {
	"camera" : {
		"pan" : true,
		"orbit" : true,
		"zoom" : true
"audio" : {
	"bgm_volume" : 0.6,
	"efx_volume" : 0.6
"alpha_welcome" : {
	"hide" : true
"tutorial" : {
	"hideStartingTutorial" : true


although perhaps they are added once you play the game and adjust the different settings. The renderer part is pretty much the same as in the stonehearth.json file.

If you get to see the game window, we could have a chance to track the crash. You can post here or by PM to the devs your “user_id” and they can check in the crash reporter log if it has been registered. It’s difficult to fix this crash if we can’t understand where it comes from. :confused: I’m reaching my limit of knowledge…
[1]: Welcome to the Bug Report Category!

1 Like

I didn’t notice anything about stonehearth in the event log, but I’m afraid I don’t know exactly what I’m looking for. I’ve never used or even heard of the thing until now, so I’m not sure what I’m seeing in the log.

As for my files, stonehearth.log doesn’t seem very enlightening:

2014-Dec-08 17:20:00.470008logger initialized
2014-Dec-08 17:20:00.509984 | server | 1 | app | Stonehearth Version
2014-Dec-08 17:20:01.106023 | server | 0 | | lua git is enabled
2014-Dec-08 17:20:04.547082 | server | 1 | resources | Modules are verified prestine.
2014-Dec-08 17:20:04.631094 | server | 1 | app | Running Stonehearth server on port 47672

user_settings.json contains literally just the following text:

“user_id” : “45530b2a-7c5c-11e4-8b58-0c84dc358ba8”

Stonehearth.json has this:

“mod_checksums”: {
“stonehearth”: “05009ff984c89cd45270bc09fdd6eefff55b56740b70acdee161912aaca4e72d”,
“radiant”: “eacf362a65b10d3ed2885e6b7fb62181a79dc3bca55d5a582dff0f0d9bbfbd97”
“renderer”: {
“screen_width”: 1920,
“enable_ssao”: false,
“enable_fullscreen”: false,
“use_fast_hilite”: false,
“enable_gl_logging”: false,
“enable_vsync”: true,
“shadow_resolution”: 2048,
“screen_height”: 1080,
“enable_shadows”: true,
“msaa_samples”: 0,
“use_ssao_blur”: false,
“use_forward_renderer”: true

I have done no editing to the files, except for changing the enable_fullscreen setting to true and back to false.

1 Like

@ousire Just a general troubleshooting thought here… you said you’ve uninstalled and reinstalled through both Steam and the Humble Bundle website. Have you tried using the zipped version of the alpha on the Humble Bundle site? Just download that and extract the zip file, no need to run an installer, just double-click on the stonehearth.exe file in the extracted folder.

I’ve tried both the installer and the zip file, and the game reacts the exact same way each time. It loads, goes white, and Windows says it’s not responding

I’ve attempted to load the game again today, just to see what might happen. I had the same issue of the game freezing up as before. After leaving the game open for a little while, it just closed itself, and I’m not sure why.

Here’s what the stonehearth.log has to say:

2014-Dec-17 05:40:09.983272logger initialized
2014-Dec-17 05:40:09.983272 | server | 1 | app | Stonehearth Version
2014-Dec-17 05:40:10.517399 | server | 0 | | lua git is enabled
2014-Dec-17 05:40:13.649521 | server | 1 | resources | Modules are verified prestine.
2014-Dec-17 05:40:13.708565 | server | 1 | app | Running Stonehearth server on port 30197
2014-Dec-17 05:43:13.874387 | server | 0 | mod stonehearth.world_generation | initialize not implemented for world generation service!
2014-Dec-17 05:43:13.905638 | server | 0 | mod stonehearth | greedy task scheduling enabled
2014-Dec-17 05:43:37.099976 Fatal Exception.
2014-Dec-17 05:43:37.099976 Total System Memory: 7.888 GB (8469368832 bytes)
2014-Dec-17 05:43:37.099976 Current Memory Usage: 90.926 MB (95342592 bytes)
2014-Dec-17 05:43:37.099976 Total Address Space: 2.000 GB (2147352576 bytes)
2014-Dec-17 05:43:37.099976 Available Address Space: 1.665 GB (1787277312 bytes)
2014-Dec-17 05:43:37.099976 Used Address Space: 343.395 MB (360075264 bytes)

Is this of any use?

I have the same probleme