[Res] Dev 2513 (x64) roofs that are 1 block high (flat) arent built

For some reason, the houses are built halfway and the workers went on to do other stuff.

Photo of the unfinished house

User ID: 87592b36-26ec-11e5-b56c-14dae91f74f7


hey there @Oreo welcome to the discourse :smile:

you did have the resources to complete it, right?

@8BitCrab Hi! :smiley: Yes, I did! I remade a new game and this still happened.

was it a custom building? if so, could you provide the template (if you saved it as one)

@8BitCrab Yes, it was! It was a 7x7 building with 2 reinforced doors and 4 diamond windows.

Pic of custom Hut

hmm… im not certain, but this could be causing the problem.

@SteveAdamo @Relyss have you seen any reports of building not being completed due to multiple doors?

edit: @Oreo have you tried other buildings, and do they not build anything or is it just that template?

@8BitCrab I went to try 2 custom buildings - 1 from my old template (2 doors), 1 new design (1 door), both also stopped halfway. However, when I tried the non-custom building, it can be built.

Edit: Ohya, I looked at my citizenscreen and it said that the workers were still building but they just stood near the fire and did nothing.

are the materials in crates? as they are known to be buggy, so perhaps try taking the materials out of the crates and see if construction continues.

I can confirm that they don’t finish buildings

for days now the wooden roof is unfinished with plenty of wood available in a nearby stockpile
scaffoldings and ladders are also still in place
it’s a custom 22x22 building with a 1 block high wooden roof with no slopes
they finished the walls and even placed the dumbledors… er… double doors correctly
but after that… none of them seems to be interested in finishing their sleeping quarters…

If they told me they like to sleep under the clear night sky I would’ve just placed the beds outside ^^

hmm… @Oreo and @FX5 you both have super low roofs on your buildings, that could be the problem, as my hearthlings built a custom building for me last night, without any problems.

this is from yesterdays 2494 with the same template and all the roofs are done
(unfortunately I don’t have a “full visability” screen and I can’t load that save due to incompatibility)

hmm… im going to page @sdee and @Albert, it appears something broke the hearthlings ability to build roofs in the 2513 dev build.


derp…I just toyed around with the unfinished roof trying to get it done
by selecting the unfinished roof part and deleting it I got an engine error

develop-2513 (x64)
stonehearth/lib/build_util.luac:277: assertion failed!
stack traceback:
	[C]: ?
	[C]: in function 'assert'
	stonehearth/lib/build_util.luac:277: in function 'create_edge_loop_for_wall'
	stonehearth/lib/build_util.luac:308: in function 'calculate_roof_shape_around_walls'
	...h/services/client/build_editor/grow_roof_editor.luac:48: in function '_compute_roof_region'
	...h/services/client/build_editor/grow_roof_editor.luac:31: in function '_filter_fn'
	...earth/services/client/selection/entity_selector.luac:52: in function '_get_selected_entity'
	...earth/services/client/selection/entity_selector.luac:70: in function '_on_mouse_event'
	...earth/services/client/selection/entity_selector.luac:80: in function '_mouse_cb'
	stonehearth/services/client/input/input_capture.luac:26: in function '_dispatch'
	stonehearth/services/client/input/input_service.luac:14: in function '_dispatch_input'
	stonehearth/services/client/input/input_service.luac:1: in function <stonehearth/services/client/input/input_service.luac:1>

before that happened I also changed the roof height number but the roof itself (or the preview of it) did’t change

i have had that problem, but it only occurred after an engine error.

@8BitCrab It seems that it really has something to do with the roof. I can built my 1 block high roof if it’s not totally flat. Weird.

well while they are happily tearing down the failed building right now I already modyfied the template to have a 2 block sloped roof… should be fine now

well then we know what the bug actually is, mind if i change the title of this thread?

1 Like

@8BitCrab Sure, go ahead~

there we go. with my tired brain that’s the best i could come up with :laughing:


btw @Oreo I see you placed chairs and tables for them to eat at…
during 2494 I didn’t dare to do that because the Derplings always got stuck froze and starved to death at these death traps

is it safe to use them now? got any incidents yet?