Flat roof where did you come from

Flat Roofs?

So I was building a new shared sleeping quarters in the building vision where you can only see the floor and no walls,but when the building was finished the roof was flat and not like the normal roof that it comes with.

Steps to reproduce:

  1. Go into the third building vision mode or the one with no walls.
  2. Build a new building.
  3. Wait for the roof to be built.

Expected Results: A flat roof

Version Number and Mods in use: Alpha 14 unstable build, no mods.


hey there @Infectiongunner, could you provide a screenshot?

1 Like

I have this same problem too. In the picture I’m providing, the two houses are exactly the same. The first one was (in the middle of this picture) was the original, and the one on the right was created from the same Template. The Hearth-ians built the roof peaked, however once the last ladder went down, the roof turned flat. I also had the view on “Collapsed” while it was being built.

Here is the Saved file:
1452810794696.zip (8.9 MB)


@8bitcrab Were you needing any further information?

@Nikia, I think we are alright for now. The devs are not working as it is the weekend, but someone (maybe @not_owen_wilson) will likely take a look at this next week (along with all the other bugs reported).


Sure. No problem. It’s really nice to have the weekends off lol


Just got this bug with a completely default house for two … in my case they built the arch on the roof but the rest was flat! I tried to get a screenshot but my game was freezing up at the time as well.

I can’t seem do dismantle or cancel building on this house either - is there an issue with getting them to take one apart when it’s messed up this way?

1 Like

perhaps you’re having this issue?



@8BitCrab Thanks! Yes that’s the issue I’m having! I think pausing it at least helped me get the interface back to try and tell the game to remove it but the game ignored my request … Before that I didn’t even have anything at the bottom of the edit/pause/remove area.

Hi everyone,
I’m trying to track down this bug but need more information. The save game provided is from A13 so it’s hard for me to use it. Does anyone have an A14 save with this bug in it? Thank you

Sorry, but not yet. This was 7 days ago when we were reporting about it. I’m currently stuck on a MacBook until next week, so no Stonehearth testing for me until then.

well i was going to try and get you a save, but i’ve tried to repro this multiple times and different ways, and yet i cannot get it to happen… :confounded:

I have come across this. I have not been able to repeat this consistently yet.

All you have done is turn on"peaks" in the NSEW positions of the roofs options. They may be highlighted but a save and restart then rebuild the building and you should be able to select the position of the peaks in the build menu. It is not at all a flat roof as a menu option but a flat section of a peaked roof due to not selecting peaks in the options menu.

You may have not selected “no peaks” in the options, but some sort of save/pause game, selection/build seems to have caused this. I’ve noticed a couple minor pause game issues lately that when you build with the pause on it… it, it’s a bit broke. Sorry for the lack of vocab, but it is.

Here you go @yshan!

I thought I had deleted this save as it had the same farmers not harvesting bug as the other save I uploaded for you in and this one was just a creative mode new game to test with… but it just happens to also have the flat roof bug on a default template house. Hope it helps.

(Still not entirely sure I’m doing this saved game upload thing right - please let me know if not)

I had this bug last night when placing templates, I delete and them tried replacing the template and it would keep on happening. Until I realised that there was a single rabbit skin sitting under neath the template. I got my hearthlings to remove the rabbit skin to storage then placed the template and no more flat roof!

Summary: Objects on ground when placing templates flattens the roof.

1 Like

Does this happen every time you try to place a template on top of an object on the ground? I wasn’t able to get it to happen putting a template down on top of a rabbit pelt or other items :frowning:
Thank you for reporting your findings!

(P.S.) Thanks for helping everyone. I know this bug is out there. I just need to catch it in the act!

Link is good for me, so I would say you are doing “this saved game upload thing right” :smiley:!

1 Like

So while building one of the template houses they kind of started building the roof improperly and then promptly hit a wall. Nothing I usually do to get them back to work was doing the trick. As you can see the second attempt on the right is going much smoother (same house).

This isn’t the first time this has happened and unfortunately I don’t know what exactly triggered it but I thought I’d point out that even in alpha 14 this is happening, and not just to the custom buildings but to the templates. This instance seems to be related to them suddenly going off book while building and getting confused I think. Really weird though since all I did to get them to work was place a template building and leave them to it.

Looks like you are encountering this bug! Can you upload the save game where this occurred? I know @yshan has been trying to hunt down this bug, so the more saves the merrier!

To upload a save, locate the folder in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the folder, and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Hey sorry for the late night response. Here’s a link to the dropbox folder. It didn’t like the .rar so I figured this would be faster.