Bug Fix "Our hands can do it, but someone told me to never build roofs"

The saying you can build a building is possible, till a hearthling complains they cannot build a roof. Like how HOW is it hard to build a roof?! And what I mean not building a roof, literally never building a roof. No matter what, shape, form, or whatever, I would like to quit stonehearth for this pesky bug, No Questions Asked.

Overall, someone has to do this, even though I’m no coder myself, but please… Alpha 15 should’ve fixed this thing…

Steps to reproduce:

  1. Firstly, I don’t know if this is on all platforms, however, any time of building’s roof’s will never finish thus never completing the building
  2. Secondly, I give up if the hearthlings decided to quit and restock useless stuff.
  3. Finally, if you try to get this bug, it mostly going to be building whatever stuff you’re trying to build…

Expected Results:
A nice detailed house filled with perfection (AKA Builder’s dream)
Actual Results:
Hearthlings on strike on building any type of roof (AKA Builder’s nightmare)
I again will say this might no comply to some versions or platforms, but this bug is really irritating…

I KNOW that this game is in Alpha, BUT I ain’t surprised this was not fixed in alpha 15. What about the castle?
I DO have evidence, the discussion doesn’t want to allow it, and video captures seem helpless…
Version Number and Mods in use:
From Alpha 15-Alpha 16 Possibly Alpha 17 if not fixed (NO MODS)
System Information:
Windows 10 Pro (latest)
Processor: Intel® Core™ i7-4790 CPU @ 3.60GHz 3.60GHz
RAM: 15.9/16.0 usable
64 bit

Extra info
If you got an ideal fix that doesn’t include the instant ‘ib’ command, then that would be certified till the next alpha…

well perhaps giving pic.s saves or scematics would be usefull. Personally i haven’t had much issue with roofs. Roofs don’t appear to be wanna placed on free standing walls if any of them don’t link up or are double. Also the roof is a bit of an issue whe you haven’t placed the bottom floor.

We also know of an issue with multiple roofs on the same level. However you can always build the roof your self with slabs. This would be the solution for custom roofing anyways so you can orm it just the way you want.

1 Like

Are you sure you’re putting roofs on your templates, have enough extra wood for scaffolding to get up there, and are allowing enough room around the building for hearthlings to build up to and around the roof so they can put it in place?

If you could post a screenshot or save file of the problem we might be able to help you more precisely. Almost all the building problems I run into are location specific.


This is mostly my best evidence, you see hearthlings just working off in fields and not focusing on this house, plus the hearthling in the top right corner doesn’t seem any help due to the roof is made out of stone and the scaffolding is up the point of building the roof. I also got some problems with 3 cottages earlier…

This is what I took and no I didn’t stop the building or neither the ability of building either. This is what I keep seeing in my screen when I tried to use the hearthling ‘therapist’

do you have the template so we can investigate?

I can give you what I did for my building. Try to make the building have some in and out sticking walls and what I did is not place any furniture inside. Then I did the roof to size 8. Then if that works, make a building bigger than before and follow the same principles. If the bug occurs then there’s the problem…

I do recall that this bug might not apply, plus if you can, make the buildings as detailed as possible and roof size 20-24.

I don’t deny that you’re having some unusual issues. Have you tried building any roofs by hand instead? Although it is a little tedious, it can often add something unique and special to your buildings, if you take the time to design some uncommon and otherwise “impossible” formats that fall outside the basic options offered through the in-game roof generator. For reference, all the roofs in this picture were constructed by hand, and my hearthlings built them all without the need to ib anything.

Also, on another note, why would you want to underclock your 4790? Running at 3.6 when stock is 4.0 minimum, especially in a CPU intensive game like stonehearth, seems counter intuitive to me.

I’d suggest posting the template and/or a savegame with the problem in this thread:


Building issues are very tricky so just trying to replicate the same template with the same approximate roof size won’t do it – they need to know EXACTLY what you were doing.

1 Like

Actually I did once to a random tower structure and while the hearthlings build this is what I saw

This is alpha 15 but it still has the same error

I’ve had that exact problem before and almost always it was due to the “slice bug.” Sometimes if you click “build” while in slice view or any view other than standard viewing mode, the building will build wrong. The few times I’ve had hearthlings do crazy stuff like try to build the roof first, that was why.

I’ve finally come to the conclusion to that the way to solve this annoying bug for a temporary amount of time is to reset everything… Yes deleted all my saves (they were rubbish) and the bug will be briefly be withdrawn, since then I’ve seen more building bugs and I display more of them into a new post later on.

Manually placing a roof can be very tiring and tricky