r223 x64 - Cannot Assign Mason

The last two x64 rounds have been much more stable for me … less overall lag and crashing so that’s going great!

Unfortunately I’m only a little ways into the new r223 and am finding I cannot assign a Mason all of a sudden. I had no problems assigning the Carpenter, Footman, Trapper, Farmer jobs. I have the mason’s hammer in a stockpile and 4 available workers (see screenshot). None of them, even when idle, will respond and take the job. It gives me the proper ability to promote the worker and accepts it (stamp and clapping signals).

Things I tried:

  • Tried to assign the other various workers instead of just one.
  • Tried saving game, exiting and loading saved game (all working fine).
  • Tried to build a second mason hammer.

None of these things worked and I cannot get a Mason to build stone things or progress to blacksmith.

1 Like

did it show any errors when trying to do so? Did you get any previous errors?

Might move it to another stockpile. just to check?

(: This is not a solution

No, there were no errors of any kind. It promotes the hearthling successfully but then nothing happens. It’s as if I never promoted the worker.

I won’t be able to test again until tonight but I will try moving the tools to another stockpile but again, there should be no reason it doesn’t work from the one it’s in. I would like the ability to lock down stockpiles for future use but as far as I know there’s no way to restrict stockpile contents from use, only specify what goes in them at this stage of the game, correct?

no you can’t lock’em down you can empty them but not block them (yet).
What i meant by previous errors are errors that showed up far before you tried to promote…