[Bug] R375 Alpha 10.5: unable to assign jobs / promote

Afternoon chaps;

Whenever I create a new game, I am unable to assign jobs to any of my workers.

The Saw and Knife both appear to be registering in stockpiles; they change highlight if the stockpile does not accept tools, workers place them. Looting them still results in them being put into stockpiles.

This applies to starting on stone or earth, on any level of terrain

2 Likes

Weird… The saw and knife must be in the stockpile before you open the promotion screen. But it’s weird that you already have put them in stockpiles and can’t use them… :confused:

Sometimes I open too fast the promotion screen and the jobs are disabled, because my workers still haven’t put the tools in the stockpiles, but closing and reopening the promotion window again works (and now we have F5 to reload the UI, if I don’t misremember).

I’ve been having this problem too. Nomatter what I try the hearthlings can never be promoted.

1 Like

So I started my city up on a mountain peek and immediately was unable to promote.
I have the saw and knife to promote to either a trapper or a carpenter but I am unable to promote to either.


well… this is an interesting predicament, isnt it…

1 Like

Are the tools in a stockpile? If they aren’t, you can’t promote settlers to the respective professions.

EDIT: Just saw the images–not sure what the issue might be. Did you try deleting the stockpile and setting a new one to see if that registers the tokens?

2 Likes

7 or so times…
Idk what caused it. I literally had just started the game. It was day 2 when I realized it.

Yeah this has been happening in the 10.5 release.


Bit of a problem since it makes it nearly unplayable.

Yeah… I started, mined away some stuff for the first day or two and then was like
"Let’s make that carpenter now" and was sadly disappointed when i was greeted with being unable to promote.

i usually make him the first day, so that my hearthlings can have beds for the first night…

1 Like

This is usually the first thing I do, honestly. The Carpenter’s essentially a god to your people at the moment. Hail the Carpenter!

3 Likes

then we must have sorta the same playing style.

I usually do the same. But seeing as my city was placed atop a mountain peek this time I decided to mine a stairway down to the lower parts of the mountain with all 7 villagers

Not to mention there wasn’t the wood to make 7 beds on the tip top of the mountain

1 Like

Same bug affects me, however, it only happens if I start on a mountain - and only then if it’s the highest level or two. Are you sure it’s on any level of terrain for you? If so, there must two seperate (but possibly related) bugs here.

1 Like

After attempting various combinations of orders and stockpile tests, I made new games. You will notice in the last line of my original post it applied starting on any level of terrain in the tests I tried

[quote=“Svelok, post:14, topic:12881”]
if I start on a mountain - and only then if it’s the highest level or two.
[/quote]then perhaps this is one bug, and the other one is related? or perhaps they are just the same bug…

Confirmed. Thanks for all this hints!. This appears to occur when the stockpile containing the promotion talisman is above 100m elevation. I’ll get this fixed asap.

2 Likes

man, i love you guys (and girls) and your game so much, because we get to be right up front chasing down the bugs with you, and you actually respond and are open about whats happening :smile:

1 Like

@8BitCrab - You guys make it so much easier for us and we love having the community help shape the direction of the game. Thanks for all the contributions to the forum!

Also, this bug is now fixed for the next patch.

4 Likes

I had this problem too. Although I closed the game, loaded and then tried again and it worked. This could be a workaround for others while they try to fix it.

1 Like