Problem Promoting a character to a carpenter

Problem Promoting a character to a carpenter
Whenever i try to promote one of my characters to carpenter it just doesnt happen. I need to get a fix to this problem bad it is very hard to play the game withought one
Steps to reproduce:

Expected Results:

Actual Results:



Versions and Mods:

System Information:

Hey there @TerminatorOfGods, welcome to the Discourse! Unfortunately we are not going to be able to provide any help without a little more information. The bug report template can be used as a guide to ensure we have enough information to assist you. At minimum can you please provide us with the version of the game you are running and the steps you take to attempt the carpenter promotion? Screenshots may also be helpful to further demonstrate the issue.

@TerminatorOfGods, have you been able to promote the carpenter yet?

The saw must be in a stockpile, I think.

Maybe he is confused with Rayya’s children not starting with a carpenter?

I have this problem too. I started a new game and I couldn’t assign anyone to be a carpenter which makes it impossible to play :pensive:

I’d been playing a normal game beforehand and wanted to start again and stream it from another computer for better performance (via Steam). However I tried the game again on the original computer and it had the same effect, so that can’t be it…

These are the steps I took: New game: Ascendency/Temperate/Sandbox. Load up as normal then went to start organising my people and assign a carpenter…selected a character, clicked the carpenter icon then approve icon which made the approved tune but on the next screen (list of chars and status etc) it hadn’t changed and there wasn’t a carpenter :frowning:

@Relyss - Thanks, I double checked the Inventory and it did have the saw in…it just doesn’t want to work


Alpha 14
No mods

System Info:
Intel® Core™ i5-3337U CPU @1.80GHz,
64-bit OS. x64-based processor

*I tried taking screenshots but I couldn’t find them on my computer :weary:


hey there @katalinia, welcome to the discourse :smile:

did you take the screenshot through steam, or with stonehearths built in screenshot feature?

1 Like

Hey @8BitCrab,

I just redid it via Steam, how to from there?

1 Like

alright, there’s probably a couple ways to do it, but the way i remember to is by,

  • find Stonehearth in your steam library
  • right click stonehearth and select “view screenshots”
  • click “show on disk”
  • locate the correct screenshot (most likely the newest one) in the folder it opens up

from there its as simple as locating the correct screenshot, then you can either upload it to the discourse by dragging and dropping, or by using the upload button

hope that helps/makes sense :slightly_smiling:


@8BitCrab you legend, thanks :slightly_smiling:

I’ve encountered this too recently but it was user error (and not having played in ages) - or UI glitch/lack of clarity.

When first starting you need to make a stockpile so your hearthlings will put away your starting goods. You can’t promote unless the required item is in a stockpile. So your initial saw exists but isn’t usable til they put it away.

IMO there is a UI fail here, because the game will let you promote the hearthling even though the required item isn’t in a stockpile - and as someone stated, nothing happens even though it feels like you just promoted someone.

To duplicate:

  1. start a new game
  2. pause as soon as you embark
  3. press c to pull up hearthling list
  4. pick any hearthling and select change job

You will see that carpenter is lit up as available (trapper too if you start with a knife like I usually do)

  1. promote that hearthling to carpenter - you get the stamp of approval
  2. let time run

Nothing happens because while you do have the saw, it’s not in a stockpile, and while the game “sees” it, the hearthlings do not

Later on if you look at job changing you get clear red text telling you that you need an item to do the promotion, but if you were to do similar steps, you could whiff (if you had the right timing and the item was made but not yet in a stockpile).

To counter this:

  1. Start new game
  2. Embark
  3. Pause as soon as you can
  4. Make a stockpile for everything as your first action
  5. Let time run for a few seconds so they put their starting goodies away
  6. Pause
  7. NOW promote your carpenter
  8. Let time run

…promotion occurs

1 Like

heh, no problemo mate, i’m here to help :slightly_smiling:

and… umm… you have the game paused (down in the right hand corner) they cant promote unless the game is playing, as they have to actually path to the item and promote, its not just an instant thing…

or does the problem happen even if the game is on play?


Hmm, I have to amend my previous comment.

I have a habit of pausing the game immediately upon embark and doing my initial setup.

IF you let the game run for a few seconds, they do actually drop the stuff they’re carrying and you can then successfully promote (just did that in the test game I was running for the previous comment).

But, if like me, you try to immediately pause and do all the stuff, the promotion whiffs because one of the hearthlings is holding the saw (and the UI thinks the saw is available so it lets it happen).

When I first had this happen, I didn’t think of it as a bug, but as user error, so I got in the habit of making a stockpile and letting time run a few seconds first thing, but that isn’t actually necessary if you let the game run a few seconds at all.

Clearly, I have no patience and/or am overly concerned with optimizing every nanosecond of the initial deploy. :stuck_out_tongue:


Hi @Voqar,
I’ve started a new game and trying it again without them having any tasks…

@8BitCrab It was whilst playing…

Yayayay it’s fixed!!! Well…I am, stupid Kat. Feeling a bit sheepish now, thanks for both of your helps guys :heart:

Now up to play on it all night (UK) :grin:


x x x


@katalinia, @Voqar, welcome! Glad you got the issue resolved.

As we have not heard back from @TerminatorOfGods, I am going to mark this #resolved until he responds with more details.

Edit: Discourse doesn’t seem to want to cooperate at the moment and let me move this topic…this is a reminder for me to return and try again later…