No Carpenter Saw in New Game

[R-519 x64] "No Carpenter Saw in New Game "

Created a new game, couldn’t visibly see Carpenter’s saw, promoted villager to carpenter but he stayed a worker, saw showed in town inventory so created stockpile for tools, later saw no longer shows in inventory.

Save File:
Dropbox - 1455138744362

Version and Mods:
Stonehearth 0.14.0 (release 519) x64 build
No Mods

System Information:
Windows 10 Professional 64-bit
AMD FX™-4300 Quad-Core Processor 3.80 GHz
32.0 GB RAM
NVIDIA GeForce GTX 650 Ti

if more system info is required please let me know what is needed

whats the cmd to insert a saw? :slight_smile:

Hi @snocat

Do you have a stock pile put down? For some reason sometimes my hearthlings start off with the tools in their backpacks and won’t put it down till there is a stock pile. You can’t promote hearthlings when the tool is in their backpack.

Update: Ah missed the part where you did put down a stock pile and the tool disappeared. Make sure to check if the worker who had the saw didn’t unload it somewhere random because of an enemy.

1 Like

that was one of the first things i tried :smiley: I’ll try an everything stockpile tho!

Hehe, yeah I totally missed that part :sweat_smile: Did you promote any footmen, I know those pesky guys like to dump their backpack inventory everywhere! Especially if they just got promoted.

haven’t yet, need the carpenter to make swords, i usually buy trappers knife on start

dang it!!! it’s fixed itself and i don’t know how

I think maybe your carpenter was on the way to get the promotion. I just tried to load your save and paused right away. The citizen menu shows your carpenter already promoted :slightly_smiling:

So it might have been the stockpile that fixed it, just it “disappeared” in the process of the hearthling getting promoted haha

I noticed at the start of my new game, I made some containers / chests that were available to everything and my hearthlings put the tools in there which prevented me from promoting one to a profession. I don’t think the game is recognizing the stored location inside a container - did you bychance have them in containers or you could visibly see them in a stockpile?

I had to empty the container the tools were in back to an open stockpile before I could promote someone.

(I do think this might be a bug but I wasn’t entirely sure about it at the time and forgot so I am glad this was brought up again).

Hmm, I wonder if it is something with the starting tools. I usually create a crate for tools when I have my worker house up and delete stockpiles that hold tools. My hearthlings are still able to be promoted from that crate. By that time I already have carpenter, trapper and a few other beginner jobs hearthlings, but I know I’ve successfully promoted farmers, footmen, blacksmith, cook, herbalist, and shepherds from it.