[R114] [STEAM Client] Town view HUD text slightly off


#1

Summary: When opening the town view the HUD text would appear slightly off. Opening this further into the game the text appears to correct itself to the actual view. Frequency is a bit spasmodic.

Steps to reproduce:
1) Open up town view at various intervals.

Expected Results: Should see correctly formatted text on the town view.

Actual Results: Slightly out of bounds on the current view.
Notes: Game is being played in Windowed mode, will see if the same effect happens in fullscreen.


GUI Bug -- "Hint Box" Doesn't Update
[Dev Blog] Alpha 4 Official Release
[Dev Blog] Steam Unstable Updated to Alpha 4 Build 118
[Con] UI freeze upon joining citizen
[Dup] Broken Town Journal UI
#2

it might be easier to spilt the list up into multiple topics because there are a few that have been made already as topics


#3

Won’t seem to spammy will it ?


#4

welcome aboard @digitalFatteh! :smile:

absolutely not… we encourage individual reports for each bug… I’ll link the report format here in a sec (stuck on my phone at the moment)…


[Res] Eternal Battle + Hungry Squirrels
#5

Already have it, I’ll cut it out from a previous area I have it in.


#6

brilliant… thanks again! :smiley:


#7

Title: Town Journal UI Broken

Summary: When the journal is opened, rather than having the two columns “good / bad things”, there is just one column that takes up the whole journal. See the attached image for a better explanation.

Steps to reproduce: I’m not entirely sure about this. It seems to happen unpredictably. I can have it not working one minute and working the next.

Expected Results: Normal journal appears, with two columns and a scroll bar.

Actual Results: Only one column with both sides joined together, overflowing from the book instead of having a scroll bar.

Notes: This has happened in most of my games.

Attachments: How it was when the bug occurred:

How it was not long after that:

Versions and Mods: Release 114, with no mods

System Information:
Processor: AMD E-300 APU 1.30 GHz (Yes, this really can run Stonehearth xD)
Graphics: AMD Radeon “HD” 6310 Graphics
Installed memory (RAM): 4.00 GB (3.60 GB usable)


#8

This was recently reported by someone else, can’t remember who, nor can I find it very easily. I think it was in a topic that was about multiple things, not just this. I also think they mentioned playing it in windowed mode “in case that mattered” or something along those lines. Will see if I can find it still and provide a link.

Did you happen to also be playing in windowed mode?

EDIT: Ah, @digitalFatteh liking my post gave me the hint I needed. I guess it was a separate topic, after all. Here it is.


#10

I can confirm this also happened in full screen mode as well:

Additionally the journal also appeared to blank itself out afterwards:

This led on to a few other issues where the HUD stopped displaying text on the lower left and the workbenches froze to their current per-queue build lists. I could add to the craft list but nothing would show up along the side even though the weaver and the carpenter would produce the item requested. Attempting to replicate.


#11

At first I thought it might have something to do with the resolution the game plays at. I’d been playing windowed mode, but maximalized to my 1680x1050 screen without issue. After having an issue with my last recording that made it only come out at 480p, I had decided to make the game itself play in a 1280x720 region (the window itself thus being slightly larger than that), and this was the first time I’ve noticed this problem. However, see below, and at 17:53 in the video.

I can confirm this as well.

Did not notice this explicitly, but I think the UI just sort of froze generally, because the debugging info in the bottom right was also frozen, reminiscent of this other bug (same but different cause? Hard to tell… but that other one at least never gave me the Town Overview dialog issues… unless I just didn’t check in those cases, since I typically noticed when checking the Citizen/Crafter Management dialogs. In fact, I believe that’s the most likely situation. I’ll check whether the Town Overview dialog is again messed up the next time I get the UI freeze bug with a joining traveler.)

All of this is visible in the video I recorded of the whole event, see below (14:23).


[Dev Blog] Alpha 4 Official Release
Impressions of Alpha 4 Release 114
#12

Instance of Journal bug. Included the save game file, log file and a couple of videos.

SAVE FILE
Log File

Video 1: Shows the journal bug and being able to open multiple workbench UI, over & over, until the screen turns black. Which may relate to this POST

Video 2: Shows the same file but different open order where the journal opens but workbench UI is unresponsive.

http://youtu.be/Q12aec7g8I4