(R-447) Certain UI windows not showing information that should be there

It would seem the latest steam release (Release-447) yesterday (8/13/2015) has a bug dealing with certain UI windows not showing information. This wasn’t happening before yesterday, so it could very possibly be this update. I tried restarting the game completely several times and even reloaded the UI using F5. It doesn’t seem to change anything. The two that are not displaying information are the Town Overview and Citizens panels. The Town Overview doesn’t display the number of hearthlings for each position. As for the Citizens panel it doesn’t display anything other than the word “Citizens” at the top and the “X” in order to close the window.

I am running on a Windows 7 Professional PC equipped with NVIDIA graphics cards.

Top Portion of Town Overview UI Image

Citizens UI Image

how long did you have the ui window open? I’ve had this happen occasionally too, but it generally fixed itself after a couple seconds, or upon closing and reopening. I also had 1 instance of it staying that way, but that was several updates ago, and seems to be game-breaking, in which case you’ll just have to reload, or, in the worst case scenario, start over.

also, as of yesterday, we’re on release 450. 447 was 2 days ago. did you get it on that build too?

1 Like

I am still on Release-447, Release-450 is an optional unstable build i thought, the reason I am probably still on Release-447 is due to me using the game through Steam and the games don’t always update with those development builds. Unfortunately though I have restarted the game itself and tried a new save. I have also reloaded the UI with F5 as I stated in the original post.

so this issue persists through multiple sessions of the game running? in that case, you could try to check the integrity of your game data, something might have gone wrong somewhere in the update, causing your UI to become wonky. also, steam should update your game upon reopening the game right now, giving you a pop-up letting you know that it’s updating, and leaving the “play game” button greyed out until it’s done updating. if it didn’t, then I don’t know how, but you should probably update to 450, and after that, check the integrity to make sure everything’s all right.

1 Like

The file integrity of the game was fine, while I was in settings I noticed that it was not set to download the latest releases. Meaning the unstable ones, so now it seems to work fine even though I had to start a new game. I’m thinking that should be one of their features if they haven’t thought of it already. A setting in the start menu so if a save isn’t compatible with the version you are on you can convert it somehow, although I am quite certain in saying that would be a huge pain to try and implement so they probably won’t do that.