Problems Re-Embarking With Modded Classes

Summary:
While re-embarking with villagers that have learned a custom class, the following error is thrown after choosing the attached re-embark file. The villagers do not need to actively be set to the custom class (they will do it even when set to worker), but deleting the custom classes from known jobs in the JSON fixed it immediately.

release-870 (x64)[M]
No matching overload found, candidates:
void __add(lua_State*,Point3 const&,Point3 const&)
stack traceback:
[C]: ?
[C]: ?
[C]: ?
radiant/modules/terrain.lua:363: in function ‘find_placement_point’
stonehearth/components/job/job_component.lua:841: in function ‘_remove_equipment’
stonehearth/components/job/job_component.lua:398: in function ‘demote’
stonehearth/components/job/job_component.lua:295: in function ‘promote_to’
…vices/server/game_creation/game_creation_service.lua:294: in function <…vices/server/game_creation/game_creation_service.lua:263>

Steps to reproduce:

  1. Start a new game with a mod that adds classes. I was using “High Class”, but after looking at the code that crashed, I’m pretty sure any custom class will do it.
  2. Play through to re-embarkation. Re-embarking itself will work fine and produce a properly formed JSON file as normal.
  3. Start a new save and pick the re-embarkation file.

Expected Results:
Re-embarking into a differently modded or un-modded game: Strip the information from the file or ignore it and leave it in the json without touching it.
Re-embarking into another modded game with that mod: Not exploding.

Actual Results:
It will throw the above error, the re-embarked characters will not replace characters in that screen, and if you start playing anyway, my normal result was to get 4 new workers and 1 or 2 of the imported characters.

Notes:
It doesn’t matter whether High Class was enabled or disabled while making the new game, whether I downgraded the workers with High Class to any other class, or what items I had equipped or brought with. The items all worked fine.

Bonus Bug:
The same save file has a completely unrelated issue where the only blacksmith that will actually smelt ingots is “Gem Woolden”. Other blacksmiths will make signs and perform some of the other crafting actions involving the anvil, but not actually use the forge.

Attachments:
Dropbox - c20c8ba9-fa99-4e87-91f6-5592f4336845.json (Re-Embarkation file)

Dropbox - 1530949432557.zip (Previous save)

Version Number and Mods in use:
Stonehearth 0.24.0 (870)
Clock Tower Barracks
TMD - Tier 1 Buildings
TMD - Tier 2 Buildings
TMD - Tier 3 Buildings
Defensive Pack
Better Storage
Crafter Queues!
The Ascendancy: Empty builds For Workshos
Sacred Grove Biome
High Class
Settlement Decor

System Information:
Windows 10 Professional
Intel Core i4770k
16 GB RAM
GeForce GTX 1060

1 Like

Thanks for the report. Fixed in the next release.