Unable to recruit certain classes without crashing

So i guess this bugged might be known or unknown to some. But apparently some classes causes you to crash when you try to recruit em to your cause of righteousness >.<… So far the class that causes me to crash is usually the Footmen. Not sure bout the other classes as i have not encountered them yet…

Thanks for your time on this!

And keep up the great works and updates team Radiant!

i reed it somewhere else too, a sometimes working solution is saving before doing anything with the pop up, and if it crashes, load the save try it again, if it crashes save another one and load that the next time, it worked for me that way, dont ask how or why

heh… I see… So far, only the worker class doesn’t crash the game. The rest of em crashes the game

had it with farmer worker and footman so far, now my save is bugged with the id error…^^

hey there @NaZulieo… are there any other steps you take prior to the promotion?

does it happen (reliably) when this is the very first action you take?

I think he is talking about scenario visitors @SteveAdamo!! , interestingly, I have had no issues.

Are you running the R130 unmodded version of the game?

1 Like

ahh, right… good point!

1 Like

yeap im running R130 unmodded

@SteveAdamo yup the senario based classes

1 Like

The next time it crashes it might be useful to post the bottom part of your stonehearth.log file. It’s quite good lately and usually tells you what the culprit is

1 Like

Stonehearth Error msg

Well here is it… sorry couldn’t really get the bottom part. Keeps appearing a lot of times

1 Like

Did a farmer join while you were plowing a field? Otherwise I’m very confused.

Wasn’t a farmer joining but a Footman. My farmer was plowing and planting

oops… i think i got the wrong SS

maybe i could help with that log-text

2014-Sep-07 19:39:35.223247 | 0 | client | starting save.
2014-Sep-07 19:39:35.260249 | 0 | client | saved.
2014-Sep-07 19:39:35.761278 | 0 | simulation.core | starting save.
2014-Sep-07 19:39:36.503320 | 0 | simulation.core | saved.
2014-Sep-07 19:39:43.150700 | 1 | lua.code | generating traceback…
2014-Sep-07 19:39:43.150700 | 0 | lua.code | – Script Error (lua) Begin -------------------------------
2014-Sep-07 19:39:43.150700 | 0 | lua.code | No matching overload found, candidates:
2014-Sep-07 19:39:43.150700 | 0 | lua.code | Point3 get_point_on_terrain(custom [class std::weak_ptr],Point3 const&)
2014-Sep-07 19:39:43.150700 | 0 | lua.code | stack traceback:
2014-Sep-07 19:39:43.150700 | 0 | lua.code | [C]: at 0x01675e00
2014-Sep-07 19:39:43.150700 | 0 | lua.code | [C]: in function 'get_point_on_terrain’
2014-Sep-07 19:39:43.150700 | 0 | lua.code | …s/dynamic/immigration_scenario/immigration_scenario.luac:61: in function 'place_citizen’
2014-Sep-07 19:39:43.150700 | 0 | lua.code | …s/dynamic/immigration_scenario/immigration_scenario.luac:68: in function <…s/dynamic/immigration_scenario/immigration_scenario.luac:65>
2014-Sep-07 19:39:43.150700 | 0 | lua.code | – Lua Error End -------------------------------

1 Like

ahh that’s probably it

second try the exact same eror, so far i can not see a class-name of the imigrant so i supose its a worker

the 4th try some ingame minutes later, all the same despites

2014-Sep-07 19:50:13.549757 | 0 | lua.code | [C]: at 0x01825e00

maybe the game wants to spawn them in something? a tree, a wall or so on


I think its part of a bigger problem.

For example

2014-Sep-07 19:01:36.540535 | 1 | lua.code | generating traceback...
2014-Sep-07 19:01:36.540535 | 0 | lua.code | -- Script Error (lua) Begin ------------
2014-Sep-07 19:01:36.540535 | 0 | lua.code | No matching overload found, candidates:
2014-Sep-07 19:01:36.540535 | 0 | lua.code | void copy_region(Region3&,Region3 const&)
2014-Sep-07 19:01:36.540535 | 0 | lua.code | stack traceback:
2014-Sep-07 19:01:36.540535 | 0 | lua.code |    	[C]: at 0x015d5e00
2014-Sep-07 19:01:36.540535 | 0 | lua.code |    	[C]: in function 'copy_region'
2014-Sep-07 19:01:36.540535 | 0 | lua.code | stonehearth/components/farmer_field/farmer_crop.luac:12: in function 'initialize'
2014-Sep-07 19:01:36.540535 | 0 | lua.code | radiant/server.luac:8: in function '_add_crop'

This bug will regularly crash your game to desktop if you “Choose crop” and select Fallow after placing a field.

I’ve only been tinkering for 2 weeks, and so this is way out of my depth - but no matching overload again.

I’ve managed to fix the ‘no matching overload’ for my mods offhand weapons, but I wouldn’t know where to begin with this. I’ve tried chasing it and end up going in circles - over to the devs I think

1 Like

For me, it crashes almost every single time I recruit a new settler via scenario no matter what class it is. On the extremely rare occasion that it hasn’t crashed, the new villager is stuck in the ground from the neck down.

receving this crash as well on any recruitment.

Version: 130 unmodded

Bug/Issue traveler joining causes came to feeze followed by crash

Steps to reproduce

  1. build village
  2. wait for traveler to request joining
  3. accept traveler
  4. watch life as they know it end

Yes that i would agree… its a pain in the a… rear bottom that it crashes everytime you try to recruit someone from the travelling “agency”.

Still enjoyable game just cant really grow the community much