Game Crashing after I promote someone to a carpenter

Hidy ho everyone, I found an interesting bug. I have a Lenovo G505s laptop, Windows 8.1, all original hardware. Everyone I promote someone to a builder, steam version or standalone version, the game freezes and crashes.

No error messages come up. The game simply locks up and then crashes.

1 Like

You mean a carpenter, right?

Shouldn’t be having much trouble with your machine or specs TBH… have you tried a clean install? I mean deleting the Stonehearth folder entirely and re-installing.


Right, carpenter.

And I have tried using the installer so far. Haven’t tried the executable. Will try that and get back to you.

Edit: Whelp, tried the zipped version too. The installer version let the game run for however long it too me to promote someone to carpenter. The zipped version just dies on me after around a minute or so.

Emailed them the problem and my specs. Oh well. Runs great on my home desktop.


Wow, this is a very strange bug. Does the problem happen with JUST the carpenter, or can you repro it with the trapper? Does it happen if you take a save from your home desktop and then load it on the laptop? (This might help you see if it also happens with footman/weaver/farmer, all of whom require the carpenter to have built stuff.)


where is the save file? And, so far no problems on the desktop. But I haven’t had a chance to even turn in on in the last week or so. I’ll try to test it tomorrow or sunday and get back to you.

1 Like

In your Stonehearth directory (eg …\Steam\steamapps\common\Stonehearth) :slight_smile: .

Oh awesome. Is it somewhere obvious like stoneheath/saves? Or is it buried?

1 Like

The folder is called saved_games.

hokay, so I the game runs fine on my desktop. I played for an hour or so, got a world going, laid out a blueprint, promoted my carpenter, and my trapper. Saved the game, and transfered it to my laptop.

It ran for a half hour on my laptop, before I had to shut it down to do some work. So it appears that the trouble only happens when I promote someone to carpenter, and only then on my laptop.

1 Like

You say you manually quit the game after transferring it to the laptop… I wonder if it would have crashed had you promoted a carpenter on it then?

What else… hmm. There’s a particle effect and such when you promote a unit… could it be a graphical issue? Wondering what your graphics card / onboard graphics are like now, because this is certainly pretty bizarre.

well, I gave it another 10 min today. I promoted a farmer and a footman on the laptop version. had no troubles with them.

I wish I could say I saw an error message, so that could help the fine folks making this game figure out where the problem is. But when I promote the carpenter guy/gal the game just locks up, and crashes. nothing in the event log, no error messages, nothing. windows just says that the game has stopped responding.

In truth, I’m not even mad. This game is amazing, and its still only in alpha atm. So bugs are to be expected, as far as I’m concerned. I just want to help make this game better.


Perhaps it has reached the crash reporter… But with this issue with user IDs that we’ve had lately… I don’t know how easily it could be tracked…


Thanks for the extra details, @mattig89ch! I’m glad to know it’s JUST your carpenter and just on level up… even though it’s still a very weird bug! :wink: If you send us a screen of your user ID (esc->file bug->screencap) we might be able to correlate it with something from our crash reporter. You can send it via PM, if you prefer, or mail it to

edit: @not_owen_wilson, though you would be interested in this.

Would my user ID be different because I transfered my saves from my desktop?

Also, I did try 3 different installs of this game. The installer, the Zip file, and steams version. I put the installer and the zip file in the same place, would that change the user ID?

1 Like

Yes, you’d have a different user id on the different machines. Send the user ID from the machine that crashes :slight_smile:

Ok then, cool beans. where is the id? I don’t see anything like file or bug under my esc menu.

Hit ESC for the main menu, go to post a bug, and then you can see the unique user ID.

so when you hit ESC, you don’t see the following options?

1 Like

Sorry for the late reply. Acutally no I don’t, at least on the steam version. On the main menu, esc does nothing. in game I see

And in the options menu I see:

Ooh, okay. Using an older version of the game in that case…

  1. Right-click Stonehearth in Steam.
  2. Properties.
  3. Betas tab.
  4. Opt in to “latest - Latest build. Minimally tested.”
  5. Update Stonehearth.

This’ll break your saved games, but it would be nice to see if this happens in the more recent builds :slight_smile: .