Post Your Alpha 7 Screenshots Here!

Radiant’s going to need to add a sentient sheep civilization/faction in addition to the bunny folk after this bug, aren’t they? Or at the very least, I see the concept lurking in the future mod forums…

(Sheep Titan?)

1 Like

I dunno about a sheep civilisation, but certainly sheep monsters could be a thing.

Also, anyone remember that little mountain farm outside Stormwind in World of Warcraft (added / updated in Cataclysm)? A whole bunch of sheep there, along with a fake one. Hit that and it blew up, sending you flying - potentially off the mountain :laughing: .

Need something like that in SH after this :slight_smile:


Outside view. At this point the game was starting to lag and crash a lot so I didn’t bother letting the outside finish getting cleaned up.

I thought I would try to build a house underground. Seems to work.

Then I wanted an underground bridge, so I did that too.

Stone storage

The whole thing. Everything just wraps around on itself so there are a few different ways to get to most places.


Entry not recommended.


that looks really cool @jonzoid :smiley:

1 Like

R.I.P. Skydock, Deepmun 1 to Deepmun 15.The roads were going along great. I used stone floors to build “curbs”, and used wooden floors underneath the road to support the ramp. Then I built a two-story house. There was the minor inconvenience of it not letting me place wall loops on the second story, which I got around by designing a second story template elsewhere. Then, it wouldn’t tie the floor to the wall loops, and therefore wouldn’t let me build a roof. I tried to design a slab roof, but then the building tool stopped working at all.

What’s the ladder of to the right, you ask? It’s a stockade, because r180 logic.X-Ray mode looks pretty cool, though. It make me want to take out my stone floor curbs and fill them with water - oh, if only we had water!


You beat me to it!! I wanted to do this yesterday but got carried away with other things, and ultimately ended my game cause of the pasture zone bug :stuck_out_tongue:

Here’s my goblin-proof, sunlight-independent, underground farm:

Requires 10 daily hours of X-ray view for photosynthesis

Here’s an odd one:

The much sought after albino sheep!

In reality, there is no albino sheep :disappointed:
This was caused by two sheep occupying the same space. For some reason they ‘merge’ and the resulting unisheep is very pale.

In any case, this sheep got jealous and wanted some attention:

Notice which way it’s facing relative to the gate

Finally, a very NSFW one:

Penn Jondal, in all her glory.
This happened due to a job change bug with the shepherd, after I deleted her pasture. It’s interesting to know that clothing disappears between job changes!


That’s not NSFW, she’s got her undies on :stuck_out_tongue: !


Some shots of my New Whiterock:


Every time my city gets close to that size the save gets corrupted.


Here is mine so far. A bridge with Shield Emblem. Then going to expand Castle around the plateau.


wow thats nice can’t wait to see the progress :european_castle: the gates are nice and the wall itself lets hope it’ll keep the goblins out :smiley:

That’s really gorgeous!

I was working on some wall patterns last night. I can’t wait for some more building improvements, especially to the slab builder for adding random detail like on your archways or at the base of your wall.


nice work @micheal_handy76_mh!

I’ve taken the liberty of renaming this thread to match @Silas’s existing screenshot collection threads… :+1:


How do you guys do that? I’ve tried doing that before but I end up not looking the way that I wanted it to be. Is it cause im still in alpha 6? I like the way it looks though!

i used, floor tiles to build sections. i only used walls to make doors and windows if need be. and build around them.

Thanks @SteveAdamo. I will be expanding this if my game holds true. :stuck_out_tongue:

1 Like

Well i got this far before the game started crashing several times. I will be stubborn and keep trying to load this to add more lol.


If your still alpha 6 please go to steam and select properties, got to beta tab and select latest to get current build. that if your using steam

ok wait a tic… I am 98.24% sure I searched for an existing thread before renaming the previous one…

there is some wizardry at play here!

no matter, the issue has been resolved… :smile: :+1: