Nordlingmod, new update!


#1

Hey all, i have been hapilly working away on my nordlingmod all the while and it’s at a point where I could use some feedback, Q&A and wishes: what would people like me to add and change? What’s good, what’s bad etc.

The dl link:
https://steamcommunity.com/sharedfiles/filedetails/?id=1384858026

Some notes:
-All workers also farm, there are no farmers.
-just found out I did a dumb with animal feed recipes needing what they do, will fix soon.
-Blacksmith either needs coal or charcoal. Charcoal can be made by putting down a charcoal mound and letting it burn till its done, then harvesting it like a tree.

Special request: if you make any good pictures with my nordlings, please share them, I could do with some better workshop images.


#2

In the Choose your adventure screen it says “A brave band of settlers from Nordlings, a society of Tough, brave Nordlings.”


#3

thanks! ill fix that :slight_smile:


#4

They seem to follow the Ascendency Questline. Are you sure you don’t want them to follow the Northern Alliance instead?

Oh also I love the every workers farm mechanic. It works well espeically in the cold climates. And early shepherd’s crook? I love it!

Found an error with the charcoal pile displaying its name as well as the wooden wall lantern (shield)

Job Opportuniteis for Villager Level 2 has a broken image

I love the charcoal mound, Clever idea! Didn’t see the harvest icon though.


#5

This Nordlings mod is pretty cool! I am trying it, and also the Trapper+ mod, and its a fresh experience.

However I found that I can’t seem to use my re-embark citizens when I start a new game as Nordlings. I instantly get an Engine error when placing the banner, and I can’t even start doing anything else. The error said something about a crop. Maybe its because other kingdom members can’t do the farming as workers that Nordlings can do. I was bringing a Blacksmith and Mason from Norther Alliance, and a Geomancer from Ascendancy.

Error code here:
release-893 (x32)[M]

radiant/lib/util.lua:158: bad argument #3 to ‘format’ (no value)

stack traceback: [C]: ? [C]: in function ‘format’ radiant/lib/util.lua:158: in function ‘format_string’ radiant/modules/commons.lua:254: in function ‘verify’ …dlingmod/services/server/job/job_info_controller.lua:239: in function ‘manually_unlock_crop’ …vices/server/game_creation/game_creation_service.lua:724: in function <…vices/server/game_creation/game_creation_service.lua:562>


#6

Could you please post or send me the save? I’ll try to take a look.
I did not account for this situation :’)
(or the save you re embark from so I can replicate it)
(the error seems to explode over manually unlocking crops :/?)


#7

Which file should I post? I’m not sure where the re-embark save file is, but I have about 5 re-embark towns to choose from, and I tried the latest one with the most recipes unlocked.


#8

any save where i can activate the re embark quest with non-nordlings, and then start a new nordling village after would do fine. so any late-game non-nordlings that have the re embark quest unlocked would do just fine :slight_smile:


#9

How can i edit your Race so they hunt like NA ?


#10

Trying to get the saved reembark file here, its from a town called Yonda*
It comes from the folder:
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_objects\stonehearth\reembarkation

https://megashare.megahd.com.br/561d9b1ff9f2f3fb7cd6d29c33f2944c


#11

Look for the NA kingdom file, it changes the “amenity” to animals. Just copy that bit and add it to the nordlings kingdom file.


#12

Hey, I’m enjoying this mod a lot, thanks for making it! Only have noticed a few small bugs mostly mentioned in these comments, but one issue I’ve not seen mentioned in these comments is that all of the Nordling axes and woodpiles never get hauled to any stockpile. Some google research suggests to me they may need like an item category or something so they can be stored, but I know nothing technical about modding so maybe I am just missing some type of stockpile or something. Looks like a viking village though with axes and woodpiles laying about the townsquare, lol!


#13

Err they are storing just fine on this end, are you using a storage mod of of any kind maybe?


#14

No, I’m only using the Rocky Mountains biome mod… It’s only the wood piles, and like I think the iron axes


#15

Ah i thought you said all my things XD, Ill check those out!


#16

I really like the changes you made to the hearthlings social order from the original game-farming villagers and battling jarl … It plays out being quite a true viking settlement! Got them living in longhouses with oakleaf roofs and stone faces (like hobbit homes)… Just figured out today how to make the roof overhangs pointed using extra blocks…

If the items sitting about persist I can use the destroy debug tool on them… The axes still get used by my nordlings, but they don’t use the fireplaces in my town, guessing since the firewood piles aren’t in their stockpile…

I’ll let you know any other issues if I find them… Runs smooth though - many mods for this game have crashed the game for me, but this one offers a lot of great content without anything being an actual issue :slight_smile:


#17

Also, do you use the ace mod or are you playing without? It’s important for me to know if you find any issues!


#18

Not using it yet. Thinking of starting a similar town with the nordling mod using ace in the future though to compare it’s benefits. When I tried to start my current town with ace added after the town was underway it froze and wouldn’t open (only tried once tho), but I’m expecting it works on a new start…


#19

Yeah I had some issues aswell with continuing a save with ace, and still working in making my mod more compatable, I think it’s playable but I haven’t had a full play through to test yet with both mine and ace


#20

Hi Wouter_Sikkema, I think theres a bug with the Blacksmith, and running ACE mod. I can’t craft the (Archer) Einherjar talisman, or a shield, because it requires a Blacksmith Anvil, and the Nordlings only make a Nordling Anvil.