No one will build any buildings

Hi, everyone.

I’m very new to the game—I’ve seen some videos on youtube but just bought it myself today—so it’s distinctly possible this is a me problem and not a game problem, but I did some Googling and couldn’t come up with anything, so here I am.

I tried designing a custom house, and had it all set to go, and hit Build, and nothing happened. Nobody moved to dig out a spot for foundation or anything. I tried this with pre-designed buildings too, and had the same problem. I tried putting the buildings in different areas. I’m not trying to build anything elaborate with more than one floor. I’ve double-checked that I have all the needed materials, and I have stockpiles and chests full of building material. I’ve checked that my workers don’t have anything to do other than build. I’ve tried setting them so that building is their only job. Nothing is working so far. I’m out of ideas.

If it matters, I’m on build 707. Can anyone offer any ideas?

They need hauling to transport buildings materials, I think.

Not true i believe, i had specialized Hearthlings for Hauling, Mining and Building each, and they’d build just fine without hauling on

They do need mining to get the foundation dug, but that might be fixed

Perhaps you could upload the save you’re playing so we can take a look into why?
It should be located where you installed StoneHearth
Zip it up and upload it here directly or via other places like G-Drive

1 Like

Welcome to the forum, @adaptation :slight_smile:

Can the workers reach the place where you placed the building template?
Please upload the savefile so that we can take a look at it, there might be a bug.

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here. (3.9 MB)

Here you go! Thanks so much for the assistance.

In the save, you’ll see that I tried to delete the house I was attempting to build, but the foundation and the roof are still there (in the To Be Built thing, I’m not sure what it’s called). I’m not sure why. Any assistance or tips are greatly appreciated.


1 Like

I don’t see anything wrong, they can build.

Tips: for removing buildings, you have to open the building menu, click on the building to select it, click on Finished Editing (not necessary if the building is currently being built or if it’s already built) and then click on the Remove button (and confirm). Don’t use the Clear tool for that, it will leave that floating roof you see. The current building editor is not very flexible, but we’re working hard on improving it and fix the bugs and UX problems it has.

For them to actually start building the game needs to be unpaused, for the calculations to take place, and then they’ll start digging the foundations. You only have 2 citizens able to build, so it might take a while for them to finish it, maybe they were eating or sleeping and it seemed that no one was willing to build anything. Also make sure the building itself is not set on pause.

Hope this helps.

I left them alone to try to build it for several days, so I don’t think that was the problem. I will give it another shot, though! Thank you. :smiley: