Workers wont start building a building

Hey guys!

Ok, so I was gonna build a fort/castle or whatever. But I didnt wanna build the whole thing in one go, so I started a foundation as seen here: (its a .json file, remove .txt extensionand place it into \Stonehearth\saved_objects\stonehearth\building_templates - you all know the drill :smile: )

fort foundation.json.txt (250.3 KB)

fort 2nd floor.json.txt (135.3 KB)

fort tower base.json.txt (82.2 KB)

When I attempt to start the building however my workers won’t do it. They dont even start digging out where the floor goes (that rules out missing materials as an issue imo) instead they are working on an almost completed road i have and mine out an area designated to farm the stone needed and as those tasks finishes they begin restocking stockpiles as if there is nothing else to do and my fort foundation stands there not even started.

Now I haven’t played this game for very long, came in like alpha 8, but I have never seen anything like this before.Is there something wrong with my blueprint that prevents hearthlings from starting building it?

Any feedback welcome, thanks in advance! :smiley:

Update: Added the next 2 steps of my fort if someone is interested of trying it out. They can be a little tricky to place, make a blueprint of voxels 2 in height in the centre of the stairs and place it on top of that. For the tower base do the same with 7 voxels up. It has to be completed in steps, else it won’t work :stuck_out_tongue:

Have you tried waiting for them to complete all their tasks and see if they start then? I’ve noticed a couple times with my Hearthlings that if I queue up a lot of things for them to do, they do it in the order I gave it to them.

Yeah, that is exactly the thing! I mean logically they should start at least digging out the ground where the floor needs to be, but they won’t even do that! As they finish other tasks they eventually begin “restocking stockpiles” which means there are no more work to be done according to the hearthlings and my fort remains untouched.

I started a fresh map, cut out some forest and placed the blueprint and nothing happens when I finish and choose to build it, despite there being nothing else to do. They just carry wood to stockpiles. Did you get a chance to try the blueprint yourself?

Ok, so I can now say where the bug was and how to duplicate it. I placed the blueprint, (1st floor + walls, 2nd floor in 2 layers and nothing else) then I edited it to remove the top 2 layers of flooring that acted as the first floor roof kind of and the hearthlings started building immediately.

Exactly how @GyroDragon described it in his topic Cutom Building not being built

1 Like

Ok, so an update on my fort… It has 2 floors and I am currently working on the third which is to end in 2 towers. Here I encountered a very strange bug, and I’m gonna have to showcase it in images:

When i Auto wall that part of the Tower the blueprint shows me the following:

How can this be? :stuck_out_tongue: I have no idea. It’s behaving like its a ground floor its adding walls to. As the picture shows its a “second floor” 11x11 voxels and when i wall it it becomes 13x13! If i try to trick it, (i added slab voxels from the inside of the tower to get up to height since the completed wall wouldnt let me place slab voxels onto it)

by building the floor slab “inside” the walls of tower

which in next step (if tricked like expected would place walls on walls) gives the correct/intended/not tricked behaviour, a 9x9 room.

So strange. I have no idea how to reproduce it, except the other tower behaves the same

Aaanyway… enough of my ramblings for now, anyone else who has seen something similar?

Updated OP with 2 more .json blueprints

You need to something like this:

I’ve shown a 4 stage process, notice for the 3rd stage I used the green highlighted flooring tool in the building designer.
When you first place the foundations and then set up your ground floor and auto-wall, the wall surrounds the border of the foundation. For floors above you have to use the slab or upper flooring tool bearing in mind that the floor edge determines the wall boundaries.

Just tried this:

It’s a blueprint (obviously!) so whether it would get built with the current issues, not sure.

At first I was a little confused by the third picture, its not exactly lined up so I thought u somehow added another depth of walls on it ^^ Anyway it looks as you did what i was trying to do, except mine bugged out and I think I know why now. As seen by this image its when you try to expand a second floor ontop of a already build room that it bugs out this way:

Yours appear fine since its a blueprint room on a blueprint room. A blueprint room ontop of a finished room yields this result. Pinging @Ponder since i think this is code-based :smile:

(This time I’ll post where its meant to be). Here is the complete blueprint I made:

Similar to yours but with wood, more plentiful at the start.

Notice the door is level with the roof of the main structure, I noticed Legobil that your doors are a voxel higher.
It also went major slow with the game freezing 15 seconds every time a block was placed on the last roof.

Where you are going wrong is:

If you don’t put a floor (circled) on the building (main screen arrow) when you auto-wall, blueprint or completed ground floor, the 1st floor walls use the ground floor walls as boundaries like the ground walls do with the foundation flooring, in others one voxel outwards.