Nihonjin: Japanese Themed Mod [On Hold]

will do! getting the kids washed up for bed (then we’re watching a movie)… but ill be back online in about 2 hours…

Okay sounds good. I’ll most likely be in bed by then, but I’ll check up on it before work tomorrow morning. :smile:

1 Like

You could try moving the copy to your desktop to see if it works


Might possibly work. Worst comes to worst if I can figure out how to make a decent table icon (doubt that’ll happen) I may have a new update in a few days that might give you better luck. lol

1 Like

worked for me… Great job!

1 Like

What is availlible on the mod at the moment, does it adds systems? or is it model/skins only atm?

And yes i meant the takeada and the other oda clans

It’s only a reskin mod at the moment. No new systems. I have very little coding experience so it’ll be a little while before I get new systems in (also kinda waiting for the moding api.[quote=“Lele99, post:187, topic:2289, full:true”]
worked for me… Great job!
Thanks! And I’m glad it works!

I plan on adding clans in somehow at some point, not sure to what extent. At the moment the banner that is in the mod has the Mogami Clan Mon on it.


something wrong happened…
i now have only 2 people when i start a game :open_mouth:

Have you tried restarting the game multiple times?
Also is this also repeatable without the mod installed?

I’ve been having an issue with both the core game and my mod that sometimes only a few villagers will appear or sometimes the fire-pit will not spawn. Restarting the game a few times until things resolve them self works for me. As it happens to me in the core game I’m not sure it’s related to the mod itself, might be similar to the building over terrain blocks bug.

@SteveAdamo Did you ever get the mod working?

no sir… but i wouldnt be concerned about it being your mod, as i have been unable to load @RepeatPan’s work either (and we all know what a smarty-mc-smartpants he is)…

i have a feeling it has something to do with my machine/client… i may try to reinstall it this evening…

Okay, keep me posted if you try again.

The only thing I’ve changed in the build i posted is overwriting some of the qubicle files and removing the original hairstyles from the male and female json files and replacing them with my custom named files, so I’m not sure what possible could cause a bug. :laughing:

No worries, we’ll manage. In the worst case, I’ll need to know what OS you use, where you have SH installed and if you are really sure that you’ve placed it in mods/. However, keep in mind that if you are using a broken JavaScript (from a broken total conversion mod), RP will likely not load. In the worst case, everything but RP could load.

@RepeatPan Hopefully after someone posts some Stonehearth Lua for Dummies tutorials maybe I’ll feel confident with looking more into your mod. :smile:

I think @Miturion asked you about overwriting the original Stonehearth files with your mod and you weren’t sure if it was possible at the moment, however is it possible to have the game access say the profession folder from a mod instead of the original stonehearth/entity/professions folder? That way you can use your own skins without overwriting the original files?

win 7 (64 bit)

default location :point_right: program files(x86)/…

im old… not senile… :smile:

however, being the team player than i am, i will take another stab at it this evening (perhaps after a fresh install), and report back to you both… :+1:

Try to see if %LOCALAPPDATA%\VirtualStore\Program Files (x86)\... contains a path to Stonehearth and if it does, what’s inside those folders.

will do! and that would make, what… 3 locations with SH content?

  • program files
  • steam installs
  • virtual store

It’s a thing with UAC and “outdated” programs. Beginning with Windows Vista, programs are not supposed to write in their own directory anymore (Program Files requires admin rights to modify files). Instead, they should use %APPDATA% or Documents or some folder like that.

If a program tries to create new files, they are instead created in the “virtual store”. It’s more or less like a “fake folder” that gets loaded too, the operation system tells your program that writing it was OK and your program can read files from the virtual store simply by trying to read the normal file. However, it makes a lot of things quite complicated and generally breaks stuff rather than fixing it.

So whenever you end up installing SH in a folder which requires special permissions, you’ll end up with this. Normally this shouldn’t be an issue, I guess. RP logs into the same folder as the stonehearth.exe’s working directory, however, which means that its logs might end up there.

Personally, I’ve disabled the protection for my steamapps folder. This means I can mess around with files without UAC’ing everything all the time and programs output stuff in the “right” location.

1 Like

@SteveAdamo, have you been able to get any mod working? Because you seem to be very much in my boat…

Pfft. You’re so senile, you’ve forgotten that you’re senile.


This sounds like my bug that only had 3 dudes… 3 of the dudes disappeared after 10 5-10 mins of play.

sadly no… but we shall persevere!

wait… what were we talking about again?

1 Like