My builds too ambitious/complex?

Exactly as the title says: Am I just too ambitious when it comes to building?

I’m on the newest build (12) although the top left says 2594, I recently updated to 2598 with no change. Builders won’t build the structure. The building is even 1 whole building as well, where as sometimes I’d end with maybe 26 buildings for just 1 (I have a feeling that’s caused by the building tools auto changing to slabs randomly)

So now, I’m stuck. I want to play this game but feel like my building ideas are just too ambitious and I really don’t want to make a small basic town :confused:

Any tips? Suggestions?

1 Like

did you make stairs connecting floors? because in alpha 10.5 when you connected them they wouldnt build it. I dont know if this issue has been fixed. best thing to do if this is the case is to design the buidling without the stairs and adding them after the building has been build.

I did make stairs yeah, but I also saved the build without stairs as well and they wouldn’t build that either. Actually, after I attempted that I also attempted to build one of the template houses. They wouldn’t build that either.

hmm strange, but do know, if you have at some point connected the floors it wont build even if you remove the staris later. because the game thinks the two floors are the same floor. just never connect the floors. but for the other templates i dont know why they wont build it

1 Like

Sounds like the same problem I am facing in the below post. Perhaps this is a specific bug introduced in the latest dev versions

Probably, though I’ve had this issue even before the latest release. I’ve never been able to finish a custom building in this game, besides a line of free standing walls and obviously very simplistic houses. Problem is, I don’t want simplistic :wink:

1 Like

Quick Update: So I attempted what Oldra said: No stairs connecting floors. I started a new game and sure enough, I have my first (ever) slightly complex custom building - almost.

I say almost because they have 1 small bit of ladder left and have yet to put the remaining doors in. Quite honestly, it’s better than nothing. :grin:

Edit: Restarted the game. They did it. Ladder disappeared and the doors all went up :joy:

1 Like

This is exactly my problem, too.
But even without stairs, my hearthlings won’t build my “west coast customs” house.

Try to break it down into steps; Build each floor one at a time -> First Storey + Doors -> Second Storey - > Third Storey + Roof

It might have to do with your connected pillars, but try the above and see if it works


Tried that myself, one floor at a time and something inevitably goes wrong. They rip up the floor for scaffold or they get to a final stage and won’t take away scaffold. In the past I have made some not bad buildings but lately…
Like @DibJib said, try to go too complicated/ambitious and you will have issues.

I think part of the issue your first building was facing may have stemmed from the number of adjacent “posts” in the walls (the brown pillars)–it seemed that many people had issues with structures like that previously. I believe most of the bugs were fixed, but it’s possible some still persist.

If you’re trying to make a rounded structure, it might be easier to draw the curves using the Slabs (free-drawing) tool, and then make walls for where you’d like actual windows and doors (note, this requires a minimum length, I believe it’s a wall voxel on either side of where you’d like it–4 for a window, and 5 for a door). It’s a pain, but that also means you’d have to draw the roof yourself. It’s daunting at first, but I’ve gotten quite used to it for my own builds (see Atralane’s Antics, where I’ve had to do it here and there).

Although, now that I think of it, another example of rounded buildings that did work is @micheal_handy76_mh’s Hearthean Theater back from…well, I actually don’t remember which Alpha. Maybe 8 or 9? Regardless, the structure should work. Maybe it has to do with the current unstable version or the way the top floor is in more slightly.

A rule of thumb for making structures I follow is always make a “normal” building first–draw the floors, raise the walls, place the roofs. Then start to add things like windows and doors (I don’t add furniture or lights to the blueprint, it’s still wonky). Afterwards, feel free to cut a hole in the floors for future stairwells or awnings. But make it after the building’s done! Otherwise, your worker’s get confused.

Another final little point (which you might have already learned) is that the building engine struggles with wide to narrow shapes; think a pine tree, for example. Going from a narrow/smaller shape to larger works fine, as the workers build another set of scaffolding once the inner part’s done. However, they have issues with building scaffolding within the base of a structure. If you look at the Diluvium City project of mine, you can see this in action: the big pillars of the Shrine had to be built by manually placing ladders, as the scaffolding only encircled the connecting floor around them (they were all one structure). Until the game can make things in “layers”, the best option is to split them into separate constructions so you don’t have to babysit the workers.

Hopefully some of these points are useful! I wasn’t sure how much of this was already known, but I figured I’d shared some of our experiences so far. Next build, I’ll try to experiment with circular structures and see if I can narrow down some of the issues.


Tried out this: The Last Hearth. Quite a few issues, quite a few saves and quite a few restarts from earlier saves. Final time was around 5-8 hours although I tried (and failed) to make the entire blueprint in one go. Did manage to combine several of the construction tools in the build in the end.

So what @jjjshab said: Try to break it down into steps

It’s a great tip really, and honestly that’s exactly what I’ve had to do. As @Oldra said, don’t build stairs right at the get go, it causes issues. So I built the main structure first which was just 2 floors and a roof, then added everything after. As the pictures show, it got built. I’ve done this with every other build and it works quite well.

However, now I’m facing worker strike issues, slightly unrelated, they just don’t feel like placing anything. :disappointed_relieved:

1 Like

Original post was merged into an existing topic: The buildings my hearthling will not build Thread