Mods from Tuhalu


All the mods that were previously individual mods are now combined as tuhalu.smod.

This mod adds 9 new recipes for the Mason, 10 new recipes for the Carpenter, 2 new recipes to the Blacksmith, 2 new recipes for the Weaver and all the objects those recipes create. It also adds the marble resource to the world, which can be mined from rock or found in fairly common marble veins.

The objects added include: 4 columns and 4 half columns, a stone double door, 6 decorative signs, a barrel, a wooden chest, 2 bookshelfs, a picnic table, a picnic bench, a picnic umbrella, a picnic table with umbrella, a golden throne and a treasure chest.

The various columns that can be crafted


The Signs

The Bookshelfs

The Golden Throne

The Picnic Items

The Containers

These are all large containers (either 2x2x2 or 3x2x2) and so are set to contain 32 items like the Large Crate.

Stone Double Door


Have you tested these mods ?
I just ask because i use the same file paths and they wont work at my stonehearth. I always get renderer.render_info file path invalid. whys that

Your models are very nice (i thought of a golden throne too)

Where did you put the mods? Are they in .smod form? Are they in the right folder?

Very definitely tested. They work fine in Alpha_10_5_3.

Also, what coasterpaul said. It sounds a bit like they may be installed in the wrong place. I sometimes goof up when I unzip one and unzip into a folder named after the file rather than directly into the mods folder. Maybe that’s what happened for you?

Tuhalu many thanks to your mod
i found some freaky mistakes in my jsons and a very anoing failure with qubicle
someone should have told me to save as “single object” when creating .qb data
now everything works IT WORKS

my Fine stone chair
(not automatically produced but craftable)
ok just seen they sit the wrong way round on my chair…


Oh yeah. If you make a single object, you have to tick single object. Almost as important, you have to untick it if you make a thing with multiple parts. I had trouble with that too, but forgot about it after except to not do it. Anyway, yay for getting things done! :smile:

and if you save the .qb in z-axis right handed they sit the right way round

Special Thanks to Tuhalu, Froggy and the cookmod
this is my first item and soon many will come to life
(there was a snowhare i think :smile: )

in your mod there is caravan level 2
is that like uncommon to buy ? which caravan is level 1 and which is level 2 ?

I don’t even remember why I set it to 2 actually. It probably doesn’t make any difference.


Tried the column mod on the latest version, works great, thanks for the mod

Mod doesn’t show up unless its a new game which gave me some confusion at first, but I eventually worked it out lol

That is standard for Stonehearth mods right now I believe. With enough modding, you can replace almost the entire game, so it would be very risky to let mods work with saves created without them.


Is there a possibility to mixinto a .less file instead of overriding ?

i try to fill up my “Fine_Stone_Craft” with the necessary parts for building but the building manager won`t show them up

To my knowledge not.

This is a bug that they’ll have to solve at some point for modding.
For the moment you’ll have to override the less file if you want to display the icons, but that won’t help because the path is hardcoded in the javascript file anyway… :persevere:


I’ve been working on adding a marble resource into the mod so my marble columns can be made with actual marble. I have been using @phector2004’s Tutorial for adding mining resources and also comparing against his Lightsaber Mod with the included crystal ore.

I’ve gotten marble dropping from regular stone no worries, but I’ve come across two issues in the implementation of ore veins.

Firstly, my implementation has an error in it. The code looks good to me in pretty much every way, so I probably need some fresh eyes to spot the error for me. Halp.

Current progress: Here

Secondly, I noticed that while phector2004’s mod has crystal ore veins in it, you can’t click on the blocks of them like you can with the radiant implemented ore veins. Edit: Turns out the highlighting is hardcoded in stonehearth/services/client/terrain_highlight/terrain_highlight_service.luac. So until Radiant exposes the list of terrain items to be highlighted in a json file, I’ll leave it alone.



Can’t really test this at the moment, but I did notice that in you data/terrain/terrain_blocks.json your code is missing a hashtag by the color modifier. Here:

  ln 4: "marble" :       { "tag" : 501, "color" : "DEDEDE", "kind" : "marble" }

Whereas it should be:

  ln 4: "marble" :       { "tag" : 501, "color" : "#DEDEDE", "kind" : "marble" }

Which I don’t think should do anything, but taking a look at the stonehearth counterpart all of the colors have hashtags. I’ll keep looking and update if I find anything else.

Thanks for noticing that. I’m not getting past the previously mentioned bug, but it probably helps prevent some other bug later.

Edit: I’ve rechecked things yet again. Tweaked a thing here and there to no effect. The error is definitely to do with the marble vein only, but I just can’t see there is any effective difference between my scripts and what is in the saber mod scripts.

Hey @Tuhalu; I think I know what’s the problem, but you won’t like it.

Mixintos don’t work well together with arrays, I don’t remember exactly why but the results aren’t what you’d expect. And in scenario_index.json you’re doing exactly that.

One solution might be to add in all the values from their array into yours in addition to having your own value. It’s not exactly the most mod friendly solution though, I think TR have to change so there’re no arrays but rather use objects instead.

As someone who used HTML before Twitter became popular… :tongue:

It’s a number sign, pound sign, approximation of a sharp sign, an octothorp(e) I really like that one, actually, and maybe, maybe even a hash sign. But colors most definitely are not preceded by hashtags! Also, stop that racket you call your newfangled music and GET OFF MY LAWN!

But, yeah, probably need a # before colors, because… tradition? I guess?


I don’t think that’s it actually. I tried putting it directly into the original scenario_index.json rather than using a mixinto and it still gives exactly the same error.

Yeah it didn’t do any difference. The bug was much much much simpler. In the manifest you forgot a ‘)’ when you’re doing a mixinto for the terrain_blocks.json.

EDIT: On the bright side it did get me to look more into how scenarios work.