Help with Modding? (Qubicle)


Hey guys! So I’ve just purchased Qubicle and I’m trying to make some new furniture items. I’m having no problem actually editing the furniture already in stonehearth but when I export it and add it to the respective file location inside “stonehearth.smod” nothing changes. I’ve looked at tons of tutorials but most are outdated or I just cant get them to work. Would be amazing if someone could help me out. Also let me know if I should change the category for this post,almost put it in support but it isn’t really a problem with stonehearth so I wasn’t sure. Thanks in advance!


Hi @crownhouses :smile:! So are you adding a new furniture or replacing existing models?


Hi sorry about the confusion! I’m trying to add new furniture but I’m using the default furniture as sort of a template.


I’m assuming you tried to replace a model as a test?

If so i can’t imagine anything going wrong, if you haven’t, try unzipping the file and editing, then re-zipping it again, also make sure they’re exported as a qubicle binary file (.qb) with compression off and with the same name as the original file


I agree with @Hyrule_Symbol. But just to be sure, have you checked your manifest? Adding new items means also adding it to the manifest :smiley:.


Welcome to the forum, @crownhouses :slight_smile:

I don’t know what are the settings in the recent versions of Qubicle, but when exporting to .qb, make sure you have these ones like this:

If you’re just replacing a model inside the stonehearth.smod to see how it looks inside the game, make sure that the file is called like the original file you’re trying to replace (save the original file elsewhere, or rename it). You don’t need to zip again the stonehearth folder once you’ve unzipped it (the stonehearth.smod), but it will make a conflict once you update the game, so it’s better to make your mod apart.

There’s this small mod to get started, don’t know if you’ve already seen it : GitHub - stonehearth/startermod_basic: A most basic starter mod to get you going!


Outdated is not a problem the core system of replacing or create entities with qubicle and bring them into stonehearth is the same as it has been 2014 (or even before)
So just try a bit of copy an paste work and replace some furniture (do not rename)
Then start modding with manifest, en.json and mixinto existing code

Just have fun to play with the jsons and don’t get frustrated if an error comes around.
If you’ re stuck ask and you will get an answer.


I think that could be it, I don’t have my computer with me now but when I get home I will try that. I’m almost positive I had it set to left-handed!


Yeah will do, hopefully I can fix it when I get home! Thanks:)


Okay I did not do that, where is the manifest located? Sorry these questions are so basic. When I get home I’ll do some more messing around with it.


Yeah I tried to just edit the .qb file for an oak tree to test it out but in game nothing changed, maybe I exported it with the wrong settings? Appreciate all the replies by the way, I’m very new at dealing with any sort of game modding.


Literally just woke up and find a notification. :sleepy: :smile: *yawn *

If I remember correctly, you are editing existing furniture models for testing right? So that would be inside your stonehearth.smod. There is a manifest.json, just inside the stonehearth folder when you open the .smod file. You can open/edit the manifest with a text editor (ex: Notepad, etc.).

Hope that helps :slight_smile:.

Oh and I almost forgot…

“No question is too basic. If a person really don’t know the answer and is in real need of it, why hesitate to ask for it?”

It’s ok :thumbsup:! Don’t be shy to ask for help :smiley:.


Thanks so much, will be sure to try this and will get back with answers! :slight_smile:


I was in the middle of replying to you saying it still wasn’t working, but then I thought “Okay, I know its a mistake I’m making somewhere so I’ll double check the manifest line I added”. I had copied another line from the manifest and changed the names to match my new item “blue_cart”. And when I double checked it I found this.

“furniture:arched_back_chair”: “file(entities/furniture/blue_cart/blue_cart.json)”,

I forgot to change the first place the item is mentioned. I fixed that and I finally added in my new item!:slight_smile: Thanks so much everyone for all the help, this issue is officially resolved:)



Darn it! Now i HAVE to make one of those ‘Great Job!’ Images!

Cingrats @crownhouses ! I look forwards to seeeing your creations :merry:


Haha :smile: .
Just because I felt the thumbs-up emoji impact… lacking :sweat_smile:. I really want to show my appreciation :persevere:.