Mining Task - Stalls

Noticed that the mining tasks stall out. No buildings above or anything like that, they just stop digging. Sometimes I can jump start it by re-selecting what I want them to mine but most times it just wont kick back on.


1 Like

This might have to do with something I noticed a while back. Is there an unmined layer on top? Does mining continue if you build ladders to that layer?

1 Like

I find I have more issues with mining when i dig down than when i dig into a wall. I think ist more of a pathing issue than anything. If you put all your miners into a group and give an attack order where they are digging it could help a bit!


[quote=“Sabatour, post:1, topic:10010, full:true”]Noticed that the mining tasks stall out. No buildings above or anything like that, they just stop digging. Sometimes I can jump start it by re-selecting what I want them to mine but most times it just wont kick back on.

In my (totally uneducated :stuck_out_tongue: ) opinion, I wonder if it’s due to pathing bugging out. I usually see this when I’ve combined several mining zones into one big one (especially if it’s rooms branching off a corridor). I’m guessing the logic goes something like this:

  1. There’s a mining job I can do.
  2. But I can’t get to it (because there’s rock in the way)!
  3. Skip mining job, go to next in priority queue.

For whatever reason, the AI isn’t comprehending the fact that the rock “in the way” in point #2 is the rock they’re supposed to be mining.

Hearthlings mine blocks in an order that tries to avoid orphaning floating chunks of earth. They aren’t always successful though. It’s sort of like the opposite problem of painting yourself into a corner.

@devoderek’s intuition is correct - if mining is stalled, it’s probably because they want to remove a block on the top, but can’t path to it. Try building a ladder to one of these blocks, and after they clear out the ‘ceiling’, the rest of the blocks will be mined out.


Thanks for the answer!

Will mining up ever be an option?

For sure it will be! But i think that wont happen for a little while!

I ran into such issues too with the current Steam build.

I tried to dig a water ditch.

  • First workers wouldn’t do anything unless I kept adding ladders close to the current front of the ditch. This seems to be a recurring scheme; Workers seem to shy from mining jobs that are several curves away (pathing?).
  • Some mines (going straight into the mountain) wouldn’t be processed at all despite being easily accessible.
  • Currently I have only a single mining job scheduled which involves removing the top layer of soil (as an attempt to build the ditch layer by layer), yet all workers remain idle. (edit: Just after I wrote this they suddenly did it.)
1 Like

Title: Settlers stop mining

Summary: After a while all hearthlings stop mining even if there is still stuff to mine. When I assign mining areas they sometimes start mining but then do nothing but sitting idle at the campfire. Saving and loading does work some times, but not for all hearthlings and does not work every time. Restarting the game has the same effect.

Steps to reproduce: As far as I know there isn’t really a step by step guide to reproduce this bug but I will describe the steps that I did in the game

  1. Start the game as usual
  2. Order to cut down a large a mount of trees
  3. Make a few large storage piles (set to accept only wood)
  4. Appoint someone to farmer (not sure if this is necessary, but in the games I played this was something I always did)
  5. Make 4 11x11 farms with carrot, pumpkins, corn and turnip and a storage pile set to foods and drinks
  6. Order hearthlings to mine (not sure if the size is important but usually I order them to mine a reasonable large area)
  7. Wait until they stop mining (which is something I have no clue about when that is)

Expected Results: Mine until the assigned area is mined

Actual Results: Stop midway with mining and sit idle at the campfire (and haul stuff if there is stuff to haul)

Notes: In an alpha 12 dev build they continued mining (although if the site was a bit too far they wouldn’t). In the attachment you can see the hearthlings idling while there is still stuff to mine. The area is also not in “suspend mining” mode.


Versions and Mods: alpha 13dev2710, no mods

System Information: Windows 8 pro 64-bits, Intel core i5-4460, 32 GB RAM, AMD Radeon HD 6570, NVidia GeForce 8600

1 Like

Hey there @QTEmmily, welcome to the discourse! (OK, you’ve been here for a while, but first post, wooo!)

Thanks for using the bug report template, always a big help for everyone involved. Now, some questions for you (sorry if they seem obvious):

Do you have Hearthlings who are workers (no jobs) with mining enabled in the citizen menu?
Can they reach the remaining terrain that you want them to mine?
Have you tried toggling (uncheck and recheck) the mine box for your workers in the citizen menu?
Can you upload this save? To do so, copy the save folder from C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and paste the sharing link here.

I wish a bug report would not be my first post, but if it helps, it helps.

To answer the questions, yes, yes, yes and yes:

I also tried assigning hauling and mining hearthlings, disabling all jobs and enabling them again, I tried building a house (which they build without problems) and I removed all storage. On that note, once I removed the storage, 1 hearthling picked up his pickaxe and mined a few blocks, but after 5 or 6 blocks, he stopped and went idle. The save is in survival mode.

I have had this problem in the latest build with Rayya’s children, but they don’t even haul on my part.

No worries on what your first post is! Mine was probably bug related as well…

Your save seems to be quite old. From what I can tell it is from Alpha 10. Can you double check that you compressed the right folder, as I have no way to open that old of a save without a time machine :wink:!

Can you clarify this? From your comment I assumed that there is some distinction between types of workers (i.e. such that are allowed to mine and such that are not), but I couldn’t find any such feature.

I have the same issue. They mine for a little bit then stop.

Hey there @klaus, sorry for the confusion. In Alpha 13 (currently in steam under the [latest] beta system), there is a new UI for controlling an individual Hearthlings tasks. For example, you can disable mining for a specific Hearthling if you want to ensure they only build or haul…if you do not have Alpha 13, that question is meaningless.

I am so sorry, I miss looked at the date. This should have the right save (else I will use the auto save):

1 Like

+1, adding a ladder fixes it but i’m sure this isn’t intentional.