Mining with help of ladders

Before alpha 11 I could mine with help of a ladder that let my hearthlings get to it.
But this is not possible atm.
Here is a screenshot of what I mean:

The ladder will be build but my heartglings will never start mining.


have you tried re-issuing the command after the ladder is built?

1 Like

Are all the hearthlings in that terrain level?
Sometimes I find that some task is not performed, only because the hearthling that was assigned to do it was stuck somewhere (for example, in a hole on the ground without stairs).

1 Like

I have raised the ladder, build it again, build another one,
I have deleted the mine(coomando), reasinged it, changed the way of mining … :smile:
I even waited half an hour … :cry:

1 Like

Here are two saves from two different games where it does not work

1 Like

Yeah, I’ve seen some other complain about not being able to mine in A11. (I could do it, so it must be a bug).


I hope that my save games help you find the problem.

Im having the same problem. No hearthling is stuck, they are all restocking stockpiles and no one wants to mine the “second floor” of my strip mine. I even tried building a slab stair case up, and that didnt help either. Something is seriously wrong here ^^

Edit: can someone confirm if they actually can get mining to work, as described by OP in alpha 11 release 2477? And also describe their process :smile:


This issue still exists in dev-2494. To be clear, mining works fine if you mine at the bottom level or mine straight down from the top. If you want to build straight into the side of a cliff after building them a ladder (like in the picture above), as you could in previous alphas, they simply never do it.

The workaround, of course, is to dig straight down, but that is problematic too. Hearthlings will get stuck, floating in the air, if the level beneath them is mined out under their feet. They can be rescued with a ladder, but this only works if you can get a ladder to them.

It seems the miners will only mine blocks if they have a platform to stand on adjacent to the zone they’re mining. A ladder doesn’t provide this for them, so they never try to mine it. If you build a little platform next to the 4x4x4 block you wish to mine, they will actually mine into the side of a cliff face.

1 Like

Here’s another screenshot in the hope it’s useful.

The three types of mining on the left are successful. Somebody can mine straight down (built a ladder so they could get out), straight into the side of a cliff face on the bottom level, or straight into the side of a cliff face higher up if a platform is built first. The type of mining on the right used to work, simply build a ladder and they’d get to work. In the Alpha 11 unstable builds, however, they will never try to mine where I’ve assigned the task. There is even an idle worker there with nothing to do (other workers were coming for that weapon and the ore), standing very close to the mining job, and he will never climb the ladder and mine out the block.


Same problem over here!


On build 2494 x64 - workers are not able to use ladders to reach digging zones above ground level anymore.

Screenshot provided:
Savegame to reproduce:

Reloading, destroying/rebuilding ladders and so on does not help. Later on this save I tried to reach an ore mine 2 layers above on different mountain layer, does not work - workers just won’t use ladders to dig above.

1 Like

This was already reported. I suppose this is already in the bug fix pipe.

Wow, that was a fast response, appreciating this :smile:

welcome to the discourse @reakktor :smile:

well, my life is the discourse :stuck_out_tongue_closed_eyes: (unless you meant @Beatrice’s reply, in that case, they probably live on the discourse too :wink: )

Don’t want to be over critical - but “supposed” usually means “you don’t know”. Is there a bug tracking system to make sure that such issues are worked on, like Jira, Mantis, Bugzilla, Redmine and whatever they are called?

Something like issue numbers you moderators can rely on too and being informed when solved ?

well members of TR always reply to the bug report topic once something is fixed… but other then that im not aware of a place where we can view the bugs that are being worked on.

but im sure that TR themselves have some sort of thing like that.

You are totally right, I’m pretty new to the board (and so to the community) so that’s why I still don’t have a precise vision of the dev’s habits.
And indeed, actually from what I saw so far, we can post bugs report but being sure it’s helpfull is another story (for exemple this bug is so obvious that there is no way the devs don’t know about it!).

just because a bug is “obvious” doesn’t mean it shouldn’t be reported :wink:

1 Like

Don’t want to get too far off topic - would be nice if DEVs would provide a bridge between their internal system and you moderators (or maybe open it to world).

Would remove a lot of hassle if at least you mods could see something like “issue[72435]: status approved” or “xxx: being worked on” or “xzy: solved in build 0815” - status messages which all bugtrackers provide as basic functions…

1 Like