Hearthlings won't mine



Select area for mining, hearthlings will not mine even when having no other tasks.

At first my hearthlings did mine but than stoped and they don’t want to mine anymore since then.


Version Number and Mods in use:
0.24.0 r798 x64


Hearthlings won't mine!

I’ve noticed this a lot on unstable too. They’re fine at first, but they let me know when they’re getting over it. They’ll literally run over and knock a single block out and then run off to do something else and ignore it. Sitting around the fire is more appealing to em and they just can’t be bothered.

Only mod we have in common is terrain_colors.


Toggling mining off and back on seems to get them back to work (for a while) for me.
I’ve also had it occur with hauling and building occasionally as well; there will be work to be done, they’ll do a little of it, then idle and ignore everything that needs to be done. Toggle off the task they’re ignoring, toggle it back on, off they go.

“Well, the supervisor hasn’t said anything about that work in a while - break time, guys!”
…you lazy little buggers…


This happens to me, too.


That also happens to me. I don’t use any mods on the unstable branch.
But what I tried today:

  • chancelled all mining tasks
  • set up one mining task (A) -> works
  • set up another mining task (B) after the first one was finished -> works
  • set up a mining task © while the task (B) is running -> workers finish their part on the task (B), then dig out one block of task © and disband mining on both areas.
  • removed task © -> workers don’t continue on task (B)
  • removed both jobs and then created the task (B) again -> workers finish that…

so it seems, assigning more than one mining area breaks mining at the moment.


there are two things I’ve noticed that can cause mining errors in this version.

  1. The area you are mining has an exposed side that both the Hearthling can reach (foot movement), but not reach the top of the mining site (mining action) (the AI acts like an idiot and doesn’t try to locate a valid position and uses only the one it finds first)
  2. You are building something and you either paused it’s construction or ran out on materials needed (the AI fails to skip the building action and try different things in the AI tree)


i thought the we refuse to mine issue was fixed last year! (i have only just got back to the gamee - stable release) and i can confirm (non-modded … appart from modding the DEFAULT_RADIUS values to give myself a bigger game… tried with default and custom values both… and it seems that this bug has not exactly been fixed… because even though they will eventually get back to work after lounging around for a day or so… they will always stop for a long time with the mining)

i agree… cancelling and re-enabling the mining task seems to help, but only temporailly


I’ve also noticed (I’m on the stable build myself, by the way) if there is even a single block where it’s kind of just hanging in the air (because they missed it when mining that spot), it will grind mining to a halt completely. Cancelling and re-enabling the mining task doesn’t work. I have to completely remove the mining ‘field’, highlight only that block, manually remove it with the debug tools and select the mining field again for them to bother going back to work. I once sat and watched them ignore a mining task for three days because there was a block hanging in the air (they could reach it, they just refused to mine it). Even highlighting JUST that block, they ignored it and wouldn’t touch it.


You cxan use a ladder for that.


Which is good to know! But, it would be nice if they wouldn’t ignore it. Especially when they CAN reach it without a ladder. You know?


They’re picky about what they can reach though, if you use the mining tool to say take off a 4x4 it’s not usually an issue. When you include the “top” layer and it makes it 4x5 they have to have the bottom layer of blocks to boost them to reach so it’s still within their 4 block swing height. Sometimes a hearthling will be a brat and mine the lower level away from around the floating block before the assigned worker can smack it or the game seems to get confused and leave the block directly underneath it as the booster block. Hearthlings can’t mine directly over their head so it’s a wash in those cases.


@groms When we extended the vertical reach of hearthlings by 1 block, we also introduced a bug that could cause mining zones to not be mined.

This has been fixed and will be in the next patch. Thanks for the save!


Really? That’s a rather strange bug. You’d think the AI would only use that reach as a test and not a starting point for finding blocks to mine; perhaps there is more that one reach indicator? odd.


I’ve noticed this on unstable, and reloading the game gets them to mine current selected areas. But if you make new area will have to reload it seems.

EDIT: No mods