macOS unstable branch live now


#41

Once the toons loaded in, the game crashes my Imac 27 after no more than 15 seconds. Crashes as in complete reboot. However, multiple Steam games are doing to me and I have no idea what to do next.


#42

Welcome to the forum, @c2beverly :slightly_smiling_face:

If it happens with multiple Steam games, then it’s likely something caused by Steam or by your computer.

However, could you upload the stonehearth.log so that devs can take a look at it? Right click Stonehearth in your Steam library, click on Properties, Local Files tab, Browse local files. It should be a text file located inside that folder.

Did you see the Apple’s crash reporting dialog? If so, could you click on “report…”, copy the crash dump and upload it here?


#43

Thanks for the report! In addition to what @Relyss said, could you share what operating system version you are using? And what year the Imac is from?

Thanks!


#44

stonehearth.log (26.6 KB)

Model Name: iMac

iMac (Retina 5K, 27-inch, Late 2015)
With 64GB Memory
And Mojave 10.14.1


#45

MAC OS Crash Report.txt (10.9 KB)
— Not sure this crash report will open. it’s an .rft but I had to change the name to .txt for it to upload
stonehearth.log (16.8 KB)
This run was no user mods and debug mod selected and it lasted about 5 seconds before hard crash to reboot.


#46

Thank you for the info!

It’s interesting, the error seems to be a kernel panic. I googled the error and it seems like it might be related to anti virus.

I see from the report that you have avast running, is there a way to disable that temporarily to test?


#47

Removing Avast only extend the time before hard crash to about 45 seconds. Just long enough I though removing the anti-virus software might have fixed it.


#48

Was it a different crash? Can you share the log/crash report if so?


#49

Once I turned on force 32 bit, it seems stable


#50

After much tweaking of the computer and chat with Apple Support, Stonehearth managed to run for about 10 minutes before an uncommanded exit to desktop. Here are the apple problem report and the log.
stonehearth.log (58.3 KB)
Stonehearth Apple Report 11-13.txt (94.7 KB)


#51

Some of my issues were from logitech driver not uninstalling and that led to a couple of other extension that to be removed.


#52

Hey that’s an interesting error! I’m not sure what’s causing it.

It looks like your mac has an AMD Radeon graphics card, and I’ve been doing all of my testing using an nvidia card. How far in the game did you get before it crashed? Have you seen any particle effects working, like the lit fire pit?

I wasn’t able to reproduce it yet, but I have just updated the mac version so that it matches the latest features on the windows version, and fixed a bug with the weather rendering on macos. Can you give the new version a try?


#53

Now that you mention it. I think the crash happened as I hit the establish your outpost quest–the first one. And it could have been the fireworks that were the problem. I revert to fallback rendering and things seem to be ok. The snow and firepit seem to be going strong.


#54

Great! Would you mind trying to run in high quality and seeing if it crashes again? I’m wondering if my patch fixed it or the low quality rendering fixed it. Thanks!


#55

Lasted for 16 minutes before it crashed hard without legacy rendering turned on. And with it turned on, it seems to be stable for hours. Also, I didn’t crash on an amd kernel…

com.apple.iokit.IOPCIFamily(2.9)[7DE930EC-AB73-3F5A-9D38-94D5EE90D197]@0xffffff7f91895000->0xffffff7f918c9fff
com.apple.driver.AppleACPIPlatform(6.1)[A5254E14-670B-35BB-8E25-BD9872872275]@0xffffff7f93c94000->0xffffff7f93d2ffff
dependency: com.apple.iokit.IOACPIFamily(1.4)[DC1D9290-BFFC-309B-8529-CCB7AB322B1C]@0xffffff7f91e3f000
dependency: com.apple.iokit.IOPCIFamily(2.9)[7DE930EC-AB73-3F5A-9D38-94D5EE90D197]@0xffffff7f91895000
dependency: com.apple.driver.AppleSMC(3.1.9)[CE000030-3AC9-3E7E-8F53-9E8E34EE631A]@0xffffff7f91e48000

I’m gun shy enough to think it might not be Stonehearth that crashed the system. I’m running virtual box I have my doubts.

Also, the search function in the building screen (the one that allows to search the buildings) isn’t working. And I had a strange bug where the daily update didn’t trigger for a game week…I restarted the game and that when away and hasn’t come back.


#56

Oh the daily update issue seemed to be linked to running in the game in fast mode.


#57

Thank you for testing it out! It really helps, I’ll take a look at the building search. What do you mean about virtual box? Are you running the game inside virtual box? Or is it just also running?


#58

I’m using Nox for Hades Star and it is running inside a virtual box. But VB doesn’t seem to unload when I quit nox. I run SH in the native Mac OS.


#59

Got it! I’m guessing it’s a problem with SH then. Also we found out why the search box isn’t working, so we should be able to find a fix. Thanks for pointing that out!


#60

I had crashes to desktop with activating the tool to mine blocks.
apple_report.txt
stonehearth.log
This happened on two different saves with raya/desert/peaceful