Just a Few Resolution Issues


I’ve been playing this game for awhile and never had a problem. However, I just recently upgraded my monitor and am now having some resolution problems (as the title suggests). I’ve tried going into the user_settings.json file and changing the width and height to but nothing seems to change.

I’ve gone so far as to attempt making the resolution 10x10, 100x100 and 10,000x10,000 to “break” the display, but it doesn’t seem to change anything. I’ve run a file integrity test which came out clean and even fresh installed the game. I’m out of ideas and am turning to this community for help… so… HELP ME PLEASE! Haha. Below are some pictures because, you know, pictures are nice.

What is the resolution you want to use?

Did you try window mode?

Screenshot res. size tells me he uses a 4k monitor, 3840 pixels × 2160.
Someone else, go fix this, I’ll be in a corner all grumpy and jealous.


3840x2160 would be great but honestly, any resolution that has a larger UI would work. Yes, I’ve tried windowed but nothing worked.

Sorry ZwoeleBeer haha!

No response yet huh?

oh! sorry about that, i saw this when it was first posted and thought i had responded :sweat:

this is definitely something for @Sweet to take look at!

Thanks 8Bit. I look forward to a response!

I’d just say “Bump” but apparently you need at least 20 characters :grin:

Hey, any news on this problem?

hey there @Fifty1Shades,

haven’t heard anything on this yet, i’ll poke the team some more for you though. :merry:

@Relyss Thanks for resolving this problem :unamused:

Can you try the unstable a22? There was a big change in that the game now fits any resolution.

If that does not work, can you delete the user_settings.json and try to launch the game? It will be created again with default values.

1 Like

@Fifty1Shades the fix is on Alpha 22. To switch to the unstable branch on Steam:

  1. Go to your Steam Library and right click on Stonehearth
  2. Select “Properties” from the dropdown menu.
  3. Hop on over to the “Betas” tab
  4. In the “Select the beta you would like to opt into:” dropdown, choose:
    latest – The latest branch