[Ack] Enabling Fullscreen in Latest Update Displays Game Incorrectly

resolved

#1

Please Note: This may be fixed with update r23 - will check.

The latest update (r22) has fixed the resolution issues users with a display less than 1920 x 1080 were experiencing and provides a ‘settings’ menu at the start screen to alter display settings.

Unfortunately enabling fullscreen within this menu can be a bit buggy resulting in your game not displaying correctly upon restart.

In order to get the game to display correctly you will need to manually alter your display settings by following these steps.

Please note these instructions are for Steam, scroll down for Humble instructions.

In your Steam library, Right click Stonehearth and then click properties

You should open this box:

Move over to local files and then click “browse local files” which should pull up this:

The highlighted file should say user_settings.json or just user_settings. Open it with a program such as Notepad, and you should see this:

"renderer" : {
	"enable_shadows" : true,
	"msaa_samples" : 4,
	"shadow_resolution" : 2048,
	"enable_vsync" : true,
	"enable_fullscreen" : false,
	"screen_width" : 1920,
	"screen_height" : 1080,
	"draw_distance" : 1000
}

You can then change your screen resolution. To enable/disable fullscreen simple change ‘enable_fullscreen: false’ to ‘true’ and vice versa.

Thanks @Albert for the clarification on the last point.

For those of you using the Humble Bundle version:


That will then open a file explorer, open your Stonehearth folder and you should see the below:

Open your ‘User Settings’ and you should see this:

"renderer" : {
	"enable_shadows" : true,
	"msaa_samples" : 4,
	"shadow_resolution" : 2048,
	"enable_vsync" : true,
	"enable_fullscreen" : false,
	"screen_width" : 1920,
	"screen_height" : 1080,
	"draw_distance" : 1000
}

You can then change your screen resolution. To enable/disable fullscreen simple change ‘enable_fullscreen: false’ to ‘true’ and vice versa.


[Dup] Advice For the latest update to Alpha 1
Game refusing to start - fullscreen mode issue
[Dup] After fullscreen mode
[Dup] Fullscreen makes game unplayable
#2

Hello,

I saw the lower resolutions were somewhat supported. I downloaded the last update and I saw the setting in the Title Menu. I selected fullscreen because I heard the UI was fixed. I restarted the game and this makes the game unplayable on 1366x768. I can’t change it anymore because I can’t get to the ‘Setting’ because it is out of the screen I can click on. When I start a new game the UI is totally out of reach and I can even place my flag. The fullscreen basically made the game unplayable for me. Reinstalling didn’t work. Any way to fix this? :frowning:


#3

Open the game directory
edit file user_settings.json (in Notepad for example)


#4

Thanks. :P…


#5

**Radiant have released a small update to the game! (yay, but no new content). **
They have added a settings button (or maybe I was blind)
Do not enable fullscreen… the reason is that is has broken my steam version somehow and I can’t fix it using the JSON files. the error that pops up is this "Options can be specified on the command-line using the format:
stonehearth.exe name1=value1 name2=value2 name3=value3
Name should be the path to the property you want to set. For example, to set this config file property:
“renderer” : {“enable_shadow”}
I have done all that it said u have to do but still it does not work using the steam shortcuts.


#6

Are you editing the settings in the JSON file, or are you altering the advanced launch options in Steam?

Edit: Initially when Alpha 1 was released I tried editing the launch options within Steam resulting in these messages:


#7

Hi BunjiNinja,

You should be able to fix this by editing your “user_settings.json” file and setting “enable_fullscreen” to false. The “renderer” node in the json should look something like this:

"renderer" : {
	"enable_shadows" : true,
	"msaa_samples" : 4,
	"shadow_resolution" : 2048,
	"enable_vsync" : true,
	"enable_fullscreen" : false,
	"screen_width" : 1920,
	"screen_height" : 1080,
	"draw_distance" : 1000
}

For future reference, any nodes in user_settings.json overrides the same nodes in stonehearth,json, which is why editing the stonehearth.json file may not have had any effect. Hope this helps!


#8

@Albert @sdee @Tom @not_owen_wilson has this been fixed with r23?


#9

no, it has not :disappointed:


#10

ahh, good to know! the latter has been most often referenced, but it’s good to know about this hierarchy…


#11

https://imageshack.com/i/10ozj1j


#12

FIX

Open game folder > Right Click “user_settings.json” Open with Notepad > Customize your screen. > Save


#13

hello :slight_smile: I just bought the game and i accidentally add the full screen option and i cant go in window mode i try to change the option on the stonehearth.json i have follow every step on this thread and now i don’t have the “user_settings.json” and i have the humble crumble thingy some help please!


#14

The instructions above are for the Steam version - I’m now downloading the Humble version to look at the steps, gimme a minute.

So @Gorenum you need to open the ‘Run’ program as below and type in %localappdata%

That will then open a file explorer, open your Stonehearth folder and you should see the below:

Open your ‘User Settings’ and you should see this:

"renderer" : {
	"enable_shadows" : true,
	"msaa_samples" : 4,
	"shadow_resolution" : 2048,
	"enable_vsync" : true,
	"enable_fullscreen" : false,
	"screen_width" : 1920,
	"screen_height" : 1080,
	"draw_distance" : 1000
}

You can then change your screen resolution. To enable/disable fullscreen simple change ‘enable_fullscreen: false’ to ‘true’ and vice versa.


Current workarounds (try these if you're stuck!)
#15

I have found it finally! it is on the thread toggle full Screen on/off and fix resolution problems where smokestacks show a link on the latest stream when he tell where to go to do it!


#16

wow, all your excellent work seems like a waste to let it sit in here… we should dump this in the workarounds thread (if you havent done so already)…


#17

Half of it is, I haven’t updated the humble bundle side of things yet. Feel free to - I’m just taking some time to look at feeding some insects to a praying mantis …


#18

done and done

the rational part of my brain knows better than to pry…


#19

Think about it for a second and I hope the message becomes clear. :wink:


#20

:bulb:

oh good grief… you cheeky :monkey: