[Bug] can't change resolution

Can’t change the resolution of the game.

I have a 1280 x 1024 monitor (5:4 ratio) and 1/3 of the screen is black.

I tried to change it in both the stonehearth.json and the user_settings.json, also in both fullscreen and in windowmode.

Also ingame resolution options is a good thing to have.

Alpha 1

since alpha 2:


I didn’t even notice this until you mentioned it. I mostly play in windowed mode, but with my 16:10 resolution I get very small black bars at top and bottom. So I guess only 16:9 is being properly supported right now.


I always adjust the width of the window so it takes the most space on my screen, and then adjust the height so I don’t see the black stripes :expressionless:

But yeah, someday I’d love to see screen resolution options :computer:


that does not work for me. Every time I change the settings in the user_settings.json they go back to default when I launch the game, both fullscreen and windowmode.
How do you adjust the width of the window?

Yea, I think so too. But black bars are hugely annoying. And they are not small, they are 1/3 of the screen.

LITTTLE TIP: just take a look in the stonehearth.json ^^ there are also some infos - perhaps when you change them too it will works ^^ i have no probs - all at Full-HD without boarders ^^

Maybe because you have the deault screen resolution. stonehearth.json does do even less. Changing fullscreen from ‘true’ to ‘false’ does not even work in there.

with fullscreen i know - but the normal resolution was lower 1024 etc. and i have upped them in both …

well maybe you have the default ratio, I have 5:4. And changing resolution in both the stonehearth.json and user_settings does not change anything.
Maybe it is a bug, maybe they don’t support some ratio’s yet.

1 Like

hmmmm i think then the best would be at first to change the title to active bug - until the devs says its not one :wink:

1 Like

Yea, that might be an idea.

1 Like

Ah… maybe I just tested with different sizes until I got the width that I wanted, and just pasted that resolution in my user settings. Because

"screen_width" : 1175,
"screen_height" : 728,

doesn’t look like a common screen resolution :confused:


What is your monitor screen ratio?

I don’t know. I have 1280 x 800 resolution, but I have the windows taskbar on the left of the screen, and slightly wider than usual. :confused:

(Also, the height that I mentioned above, makes the game have the black stripes, but I guess I got used to it, as I have the window occupying all the width that it can).

Ah ok. So you have the same problem. I thought you got rid of the black bars.


No, no, that’s impossible without being able to change the ratio, as you’ve said :sweat_smile:

I just try to ignore them or make them disappear by resizing the window until I can’t see them :sweat_smile:
I guess it’s unimplemented? I don’t remember well, but I think that the black bars happen almost since always? Your screenshot from alpha 1, doesn’t have the correct size either, since the hammer is not centered in the window (I didn’t even get to the hammer, since I wasn’t even able to see the crates next to the banner (ah, the nostalgia)…)


Yeah I remember :smile:
I was barely able to click the barrels.


Don’t know if this is a bug or not, but in the recent update to stonehearth, I’ve noticed that I’ve now got black borders on the sides of my game where as I don’t believe I did before.

Last Version (r450):

Latest Version (r453):

Both of these were taken in window mode, with the same monitor resolution for both (1920x1080).

Silly question (your answer will probably be yes): same resolution, ok; but same window size?

It’s when you resize the window when the black spaces appear. As far as I know, the game’s resolution is fixed, but the size of the window is stored in the settings according to what you’ve set.

I would assume so, as both times the window was maximized. That being said, I’ll look more into it as these pictures are two different sizes.

1 Like

You can delete this post, you’re onto whatever it was. Previously I had my start bar on the right side of my screen, where as currently I’ve got it at the bottom. That (I guess) causes the window dimensions to change, and thus removes or adds the black bars. Sorry for the false post.