Item Limit should have toggle switch

If you a computer with 32g ram i7 8 core SSD hard drive an titan z graphics card 4K . I would like to see toggle switch on Limit an say this ( turn on at your risk). So if game crash or slowed , or up the Stone Hearth game resources for people that have high end computers. Then we could help find video game memory stack overflow, an so forth. It would be great for end game play , I could understand for single game play an not multiplayer games.

There is an option to turn off the item limit in the options.

Edit: Maybe there isn’t. I thought they said they added the option, but I guess not.

If you have WinRAR or anything that handles compressed documents, you can simply head to the install directory of Stonehearth, find the “mods” directory, and open one of the following files with a text editor depending on which race you want to play:


Rayya’s Children:

Find a line that says:
"inventory_capacity_equation": "math.max(num_citizens * 150, 1200)",

In the formula above,
1200 is the default capacity if you have less than 8 citizens (8*150=1200)
num_citizens is the number of your citizens
150 is the amount of storage each new citizen adds to the capacity

num_citizens is a variable, the other two are constants. If you change 1200 to whatever number, you start with that amount, if you change 150 to whatever number, each new hearthling will increase your capacity by that number.

However, this only seems to work in newly created games. I tried loading saved games, but it did not change the inventory cap.

Edit: I remember one of the devs saying there’s a line somewhere with a “true/false” thingy among the files that either enables or disables infinite inventory, but I can’t seem to find it now.

1 Like

I think i remember them saying that you have to add in the line somewhere, but i’m not quite sure where and what.

Edit: I found it.

“mods” : {
“stonehearth” : {
“default_storage_filter_none” : false,
“enable_cpp_ai” : true,
“enable_speed_three” : true,
“max_citizens” : 40,
“show_hearthling_paths” : false,
“infinite_inventory” : true
It goes with these. Make sure to add a comma after the last option, otherwise you’ll get an error!


Found it!
Special thanks to the 1ByteCrab :grin: (@8BitCrab)

user_settings.json is in the root of your Stonehearth directory.

Basically you have to add:
"infinite_inventory" : true
After the line that begins with:
"show_hearthling_paths" Don’t forget to add a comma to the end of this line.


Lol. You replied right as I was editing my post with that! Great timing.

1 Like

a word of warning!

(i hope you don’t mind me saying this Yang) but @yshan said the she won’t be answering to performance reports from people that are using the infinite inventory, as part of the reason the inventory limit was put on is to help with performance.