[Mod Request] Remove Inventory Limit

I play Stonehearth on Peaceful Mode with podcasts playing and study at the same time. Therefore, I usually leave a lot of orders at the same time and check back every 5-10 minutes or so. Therefore, the whole inventory limit is very annoying for the way I play the game. It would be extremely appreciated if someone could make an *.smod file which removes the inventory limit. Thanks a lot.

If you mean making a black hole container i think i can made something like that. But no promises.

You really don’t need a mod for this, though. I’m not sure a mod even could, but it’s even simpler than that.

[Incoming copy-paste:]

There’s a very easy way to do this if you’re willing to poke around in your user_settings.json. [This is in your Stonehearth folder; for me it’s in C:\Program Files (x86)\Steam\SteamApps\Common\Stonehearth.] It’s really just a plaintext file, so even Notepad would work.

So after the last option you have, you’ll want to add a comma, press enter, and type "infinite_inventory" : true.


Actually, it’s a little more complicated that @coasterspaul stated, as that option isn’t in that file anymore (at least not for me). It’s still easy though.

Setp 1:

  • Go to …\Steam\steamapps\common\Stonehearth\mods\ and extract stonehearth.smod to a folder. 7zip works best for this.

Step 2:

  • Go into the extracted folders, and find inventory.lua. The address is …\services\server\inventory. Open it using your favorite editor, but notepad will work.

Step 3:

  • Change [ local INFINTE_INVENTORY = radiant.util.get_config(‘infinite_inventory’, false) ] to true.It’s right at the top and not hard to miss. Save and close when done.

Step 4:

  • Repack the extracted folder, and use it to replace the pre-existing stonehearth.smod. Also make a backup of the original just to be safe.

Step 5:

Just note that for some reason, this does mark your game as modded in the version number.


Yeah, it does seem the user_settings value is overwritten now. I’ll note that for the next time I have to do my copy-paste.

@coasterspaul your way does works, and is the correct way.

Because you are modding the game lol

Anyway, I tested and it works with just changing the user_settings like in the post coasterspaul mentioned.

All you need is to go into that file and inside mods -> stonehearth add the “infinite_inventory”:true. Note that each line has to end in a comma except the last one.


Really appreciate this. Like this method so much better.

Can confirm this works too:

Though, this does make me wonder what other hidden options are out there?


I did it quickly to test but somehow it wasn’t working… probably just a JSON syntax error on my part :blush:

1 Like

Everything is fine up to this point. There is no option using 7zip to “repack”, only to “compress” or “add to” “.7z” or “.zip”. There is no compress or add to “.smod”. If I add it to a zip or 7z file then change the extension, and try to use that file, the game refuses to load.

Edit: I figured out my problem. To “repack” one must compress to a zip file and rename the file extension. Moreover, one must be very careful that one compresses the stonehearth ‘folder’ that results from the original extraction, not simply the ‘contents’ of that folder.

1 Like

If you read the rest of the article, @BrunoSupremo found an easier way to do this without having the mod the game.