Incapacitated worker with no rescue button

I have a worker laying on the ground in an incapacitated state. There is no rescue button.

Steps to reproduce:

  1. Worker was trapped and starving
  2. Created a path to the food source
  3. Fell to incapacitated state while on this way to food
  4. There is no button to call for rescue, and he is just stuck in that state now.

Expected Results:
M y understanding is that there should be a reset button so the town can come save him.

Actual Results:
He is laying there stuck in an incapacitate state

I have tried saving/reloading several times. I have also tried using reset on him. Neither worked.

Version Number and Mods in use:
release-860 (x64)
No mods

System Information:
Windows 7 machine… 32GB ram, i7, Nvidia Geforce GTX 980 Ti Matrix.

Welcome to the forum, @zerogravityx :slightly_smiling_face:

Starving hearthlings will directly die, he shouldn’t have entered incapacitation.

Could you upload the savefile where this is happening?

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Apparently I cant upload because I am a new poster here.

Unfortunately that hearthling is doomed :confused:
You’d need to use debugtools to kill him :cry:

Not sure how this could happen, I haven’t been able to reproduce it.

Might be worthwhile to try it out both in singleplayer and multiplayer. I dont know @zerogravityx was playing multiplayer or not? But in multiplayer you sometimes get out of sync with the others so that may be why the hearthling was incapacitated? << Just a guess though

I was playing single player.

I used destroy on him in the console… Poor Luke Cage…

1 Like