Hearthlings not considering rescue as an action


#1

Summary:
I am so done with this bug
Steps to reproduce:

  1. Have someone die
  2. Have someone get scared after picking up the incapacitated body, consequently dropping it
  3. Restart the game/Press rescue a million times/Cancel all the jobs

Expected Results:
People actually carrying the back
Actual Results:
They all just ignore and let the incapacitated lie there and die, no one sees them, no one cares, all steps in 3 don’t help at all. It has the same kind of effect if you get your fighters attack in the water. They just ignore and don’t do anything, but the action is there.
Notes:
How do I deal with this problem? I tried to look for console commands, but there doesn’t seem to be one that could help. Only destroy helps, because it doesn’t count towards a hearthling actually dying, but instead, the body just disappears, dropping all the contents
Attachments:
1550161186607.rar (4.3 MB)

Version Number and Mods in use:

System Information:


#2

As far as I know from playing, only those villagers thst would haul go get them, if there is too much stuff to haul and the AI is over taxed they just won’t do it. I have found teleport Ing the corpse close to the town centre/a road helps since it makes it easier for the pathfinder, as a bit of a work around. But yeah it’s a bit daft.


#3

Oh, that’s a very good point. I have an abundance of stuff to haul so that’s a mistake on my part (although most of my chests are empty). But ye, it’s still an issue considering they prioritize the “corpses” (cause they’re not dead, but it’s easier to type) whenever they appear. Why can’t they still have it high priority after dropping?
Anyway, thank you very much. That info really helped a lot, I’ll periodically add job breaks now and leave only haul on. :ok_hand:


#4

np man, its also why those amberstone auto crickets are worth their weight in gold XD
(all they do is haul, never eat, never sleep, just clear up your town :stuck_out_tongue: )


#5

So, I’ve mostly cleared out the whole area
My only cook and and a worker are minute away from dying
Meanwhile…




NOW it’s getting reeeeaaally frustrating :upside_down_face:
Why do they just stand there, idling about? Fix this AI or add a console command, please :frowning:
And ye, by the time I screenshot the last one, they died, cause I paused it instead of setting speed to 1… But they were there the whole night. Actually, they sat around the campfire the whole night


#6

Do the victims have owned beds that are inaccessible?


#7

There may have not been a bed for the worker, but there are definitely beds for the cook and the previously deceased mercenary since they were from the beginning of the game (modified with beam mod). Although they may have been in a building that hasn’t been completed yet. But I remember in my previous game when the lack of beds happened, the injured were put in the others beds. But I’m not sure. All in all the beds were very accessible, just one door and some stairs, but they were in an unfinished building.


#8

Did teleporting the victims closer to your hearth allow them to be rescued? Just trying to narrow down what the issue may be.


#9

Didn’t try due to previous unsuccessful attempts… Should’ve tried, ye…


#10


Ok so this run is clearly cursed. I also tried teleporting the previous 2 cause my autosave was right when they died, didn’t help. In total 9 people have died, and all of them weren’t saved. Although I’m not mad as I should be, because it does add some fun to the game. Like having a new generation, cause almost all that died are my army… But still, this bug is outrageous :confused:


#11

not ene sure how you manage it though, i havent lost a hearthling in FOREVEVER because the down-but-not-out- state can be had as much as you want XD there isnt a three-strikes-your-out sort of thing


#12

Ye, the funny thing is, it’s not three-strikes-out, it’s actually once. They all died once, or rather, incapacitated :sweat_smile: :thinking:


#13

I loaded up your game. Hearthlings can’t path to the upper levels of your building where all the beds are, because the stairs don’t give enough headroom. So they’re trying to rescue your downed citizens and return them to their assigned beds, but there isn’t a path to get them there. As soon as I teleported Mithos’ bed to a pathable location, he was rescued.

Edit: In your other game, where they were returned to other beds, they were probably being returned to other unowned beds, but there were no such beds accessible here. There was an iconic comfy bed sitting on one of your traveler-assigned beds in your main building, and I placed that on the ground outside and your downed citizen could also immediately be rescued to that bed. I also used the debug tools item dropper to place a firepit on the ground outside, and they were also immediately rescued to be placed near the firepit, which is the third rescue option.


#14

Oh wow, really? Thank you very much. I did not consider the stairs-ceiling height because I thought it is default to fit in the stairs as well. Also, did not know they can be rescued to a fireplace.
Well, that explains everything, thank you again, I am very grateful. Will be more careful when building space-efficient skyscraper-inns.
I just made that up.
Also, sorry for ranting much about the bug, clearly was my fault. Although I hope ACE or some other mod could add a notice if there is no place for hearthlings to be rescued to.
Well, thank you, again, for helping with the problem.


#15

I’m making a small addition now to ACE to fix what appears to be a base game bug: they left off the “firepit” material tag of the upgraded hearths, so only regular firepits would be considered acceptable rescue destinations, when the clear intent was to make it be any hearth.

Edit: though it looks like the Veloren Elves mod you’re playing with will also need to add that material tag to their hearth if they want it to be used like that.


#16

That’s a good FYI for all modders I think Paul, just tags right? Gotta add those to both of my kingdoms aswell